'Close other tabs' does not close all the other tabs

RESOLVED DUPLICATE of bug 173703

Status

SeaMonkey
Tabbed Browser
RESOLVED DUPLICATE of bug 173703
16 years ago
10 years ago

People

(Reporter: Daniel Clemente, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021018
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021018

'Close other tabs' does not close all the other tabs.


Reproducible: Always

Steps to Reproduce:
1. Open Mozilla. Your home page should load in the first tab.
2. Open a new tab clicking the button at the left. A blank page named
"Untitled" will open.
3. Open another tab the same way.
4. Open another tab the same way.
5. Open another more tab the same way.
6. Now, right click the fourth tab (the last) and select "Close other tabs"

Actual Results:  
There are two "untitled" tabs.

Expected Results:  
There should remain only one tab, called "untitled".

I noticed that, after testing it for a while, Mozilla was becoming incrementally
slower at opening tabs; but I can't confirm it.

Comment 1

16 years ago
Confirmed on Linux 2002101701

Comment 2

16 years ago
Can confirm this bug for Mozilla 1.2b build 2002101612 on Mandrake Linux 9.0

Comment 3

16 years ago
This also happens on windows as well (netscape trunk build: 2002-10-21-08-TRUNK)
(Reporter)

Comment 4

16 years ago
OS -> all    (from comment 3)
Platform -> all    (probably)
OS: Linux → All
Hardware: PC → All

Comment 5

16 years ago
Confirmed with Mac OS 9.1 Build 2002102508.
- With 4 tabs, close 2 tabs, ans the remaining (active?) tab contents is blank.
  After that there is no way to use the window. 
  (ie Clicking on home, or on the Mozilla icon does nothing)
- With 6 tabs, close also 2 tabs ....

I have tried also with the leftmost key.. Same thing

I have created tabs clicking on a link and pressing the command key
(Reporter)

Comment 6

16 years ago
Can someone mark it as NEW, please?

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 7

16 years ago
Suspect this is a dupe of bug 173703. Just marking depends, for now.
Depends on: 173703

Comment 8

16 years ago
It works now. Mac OS 9.1 Build, Build 2002110408. See my comment 5
I have only bug 173703

Please retry with a new build
(Reporter)

Comment 9

16 years ago
It continues occuring on Linux 2002110508.
And yes.... maybe is a dupe of bug 173703... it's not like 173703 in itself, but
similar to some of its dupes.

Comment 10

16 years ago
jag: btw, I noticed that close all tabs is really inefficient when the leftmost
tab is selected and you close all tabs except the rightmost.

Comment 11

16 years ago
Another effec, 100% Reproducable with my 
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021103

1. open http://www.skiffy.com/
2. button "new tab"
3. open in new tab: http://www.braunschweig.de/
4. right mouseclick: close other tabs
   expected: skiffy closed, braunschweig remains
   actual: sciffy closed, braunschweig remains, but without contents. shift+reload
            will not help: something is loaded, but not shown, grey window remains

Comment 12

16 years ago
Created attachment 105745 [details]
screenshot

see #11

Comment 13

16 years ago
OK, so bug 173703 is fixed, can someone try this one again?

Comment 14

16 years ago
I could easily reproduce this in the latest 1.2-build where bug 173703 is _not_
fixed, but not in the latest trunk (2002111308) where bug 173703 is fixed.
Resoving as dupe, please reopen if someone is able to reproduce in the latest
trunk-nightly (identifies itself as 1.3a).

*** This bug has been marked as a duplicate of 173703 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.