Creation time of folders changes

RESOLVED FIXED

Status

--
trivial
RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: mbockelkamp, Assigned: kveton)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016

The displayed creation time of the subfolders changes sometimes (seems to be
randomly, but the tens of minutes seem to be affected mostly), e.g. if the site
sais "10/17/2002 01:24 Verzeichnis <A
HREF="/pub/mozilla/releases/mozilla1.0.1/">" then maybe an hour later it sais
"10/17/2002 01:04 Verzeichnis <A HREF="/pub/mozilla/releases/mozilla1.0.1/">"

Reproducible: Sometimes

Steps to Reproduce:
1. Open ftp://ftp.mozilla.org/pub/mozilla/releases and save the page.
2. Wait for an hour.
3. Open ftp://ftp.mozilla.org/pub/mozilla/releases and save the page.
4. Compare the saved pages.
Actual Results:  
The folder times changed while all other info is unchanged.


Expected Results:  
All info should be unchanged.
I don't know a way to fix that...  there's actually 4 different servers, I
believe, that are behind a round-robin DNS, so you get a different server at
random every time you hit it.  It's kinda hard to make the upload happen on all
of the servers at the same time... :)
(Reporter)

Comment 2

16 years ago
Maybe the servers could add a comment containing their name, ID or whatever can
be used to see the difference in the output of the LIST command.
The ftp mirror system has completely changed since this bug was filed.  I can't
imagine the change having fixed this though, and I don't know if it's worth fixing.
Assignee: endico → kveton
Component: Server Operations → FTP: Mirrors
(Assignee)

Comment 4

14 years ago
We're not using FTP anymore for the main rotation.  Thank god.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.