Navigator crashes when simultaneously loading a second page while using a "select" type form element on the current page [@ objc_msgSend]

RESOLVED DUPLICATE of bug 168051

Status

Camino Graveyard
HTML Form Controls
--
critical
RESOLVED DUPLICATE of bug 168051
15 years ago
15 years ago

People

(Reporter: James Coole, Assigned: Brian Ryner (not reading))

Tracking

({crash})

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021018 Chimera/0.5+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021018 Chimera/0.5+

Navigator crashes when simultaneously loading a second page while scrolling (by
holding scroll arrows) in a "multiple" type of a "select" type form element on
the current page in the same window.  The application hangs (displays a cursor
with a beachball badge) when the second page is displayed and subsequently crashes.

Reproducible: Always

Steps to Reproduce:
1. open a new browser window in Navigator
2. go to the page at "http://bugzilla.mozilla.org/query.cgi" in the new browser
window

3. press the "Search" button
4. press and hold a scroll arrow of the "Target:" box BEFORE and UNTIL the new
page is displayed
Actual Results:  
1. Navigator hanged (displayed a cursor with a beach ball badge) when the new
page was displayed
2. Navigator crashed shortly after the new page was displayed

Expected Results:  
1. Navigator should have displayed the new page
2. Navigator should not have hung or subsequently crashed

This occurs even after launching with an empty "~/Library/Application
Support/Chimera" folder.  I will also include a crash log generated by the crash
experienced by following the instructions I have given to reproduce the bug.
(Reporter)

Comment 1

15 years ago
Created attachment 103448 [details]
an associated crash log
(Reporter)

Updated

15 years ago
Attachment #103448 - Attachment description: an associated crash report → an associated crash log

Updated

15 years ago
Keywords: crash
Summary: Navigator crashes when simultaneously loading a second page while using a "select" type form element on the current page → Navigator crashes when simultaneously loading a second page while using a "select" type form element on the current page [@ objc_msgSend]

Comment 2

15 years ago
Confirmed using Chimera/2002101504 on 10.1.5, although no crash report is
generated. James, please retest and verify that the crash report you attached is
correct; be sure to check the time of the crash.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 168051 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ objc_msgSend]
You need to log in before you can comment on or make changes to this bug.