Closed Bug 1754722 Opened 2 years ago Closed 2 years ago

hotkey shortcut to edit bookmark should be E not I

Categories

(Firefox :: Bookmarks & History, enhancement, P5)

Firefox 97
enhancement

Tracking

()

RESOLVED FIXED
100 Branch
Tracking Status
firefox100 --- fixed

People

(Reporter: forum4, Assigned: scunnane, Mentored)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:97.0) Gecko/20100101 Firefox/97.0

Steps to reproduce:

Hello,

would be great if in Bookmark Manager (Ctrl+b) -> r-click on a bookmark -> "e" for edit (instead of "i" for "i don't know why it is i")

it's a minor thing but could have big impact on everyday routines: intuitive hotkeys & shortcuts

(and Mozilla developers surely have all good reasons why things are how they are)

Actual results:

when r-clicking on a bookmark the fast and intuitive way would be to press "e" for "edit", but when pressing "e" nothing happens.

instead the user is supposed to press "i" (which is in the space of the right hand and thus inconveniant to reach, when the right hand is busy operating the mouse)

Expected results:

when r-clicking on a bookmark the popup-menu opens (so far so good), while leaving it open and pressing "e" the "edit bookmark dialogue" should pop up allowing for modifactions of the bookmark.

  1. always say something positive first (should be the default protocol for all communications)

"THANKS FOR YOUR HARD WORK AND DEDICATION" making Mozilla Firefox better and better and better :)

The Bugbug bot thinks this bug should belong to the 'Firefox::Bookmarks & History' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Bookmarks & History

I'll set it as an enhancement so the engineering team could decide if they take in consideration changing this or not.

Status: UNCONFIRMED → NEW
Ever confirmed: true

The reason i was picked was because e was already used by Remove Bookmark, there was also Remove from toolbar using r.
Then Bug 1714478 changed it to Delete Bookmark, and used d, that pretty much freed-up e.
The only other thing on this menu that uses e is Manage Extension that cannot appear at the same time as the bookmark item, so it should be ok to use e for Edit Bookmark now.

Mentor: mak
Severity: -- → N/A
Priority: -- → P5
Assignee: nobody → scunnane
Mentor: mcheang
Attachment #9269716 - Attachment description: WIP: - Bug 1754722 - Change access key for Edit Bookmark from i to e. r?mcheang,mak → Bug 1754722 - Change access key for Edit Bookmark from i to e. r?mcheang,mak

Adding dependency due to conflicting access key change.

Blocks: 1754805
Pushed by mcheang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/08ad4b3c54bf
Change access key for Edit Bookmark from i to e. r=mcheang,fluent-reviewers
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 100 Branch
You need to log in before you can comment on or make changes to this bug.