Browser doesn't load page at the specified URL when Memory Cache setting is 0

VERIFIED DUPLICATE of bug 184304

Status

()

Core
Networking: Cache
VERIFIED DUPLICATE of bug 184304
15 years ago
15 years ago

People

(Reporter: Dan Yefimov, Assigned: gordon)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
While trying to browse page at the specified URL browser doesn't even start
loading in condition that Memory Cache setting is set to 0. If that URL is
entered in the new window/tab, it is replaced with the "about:blank" string.
After setting Memory Cache setting to value other than 0 the page is loaded and
displayed just fine. Additionally, if after unsuccessful attempt to load the URL
while memory cache size is 0 one sets memory cache size to a non-zero size,
presses "Clear Memory cache" and "Clear Disk cache" buttons, and then tries to
load that page again Mozilla is crashed (TalkBack incident TB12777928Y, reported
at 10/19/02 15:46 GMT+4)
(Reporter)

Comment 1

15 years ago
Oops... Forgot to give Mozilla Build ID - 2002101808

Comment 2

15 years ago
confirming - tested on mac osX and winNT 2002102308 trunk, os to ALL
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows NT → All

Comment 3

15 years ago
url not loading is bug 184304 (see bug 184261)
crash is bug 196917

*** This bug has been marked as a duplicate of 184304 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
VERIFIED/dupe.

http://webtools.mozilla.org/web-sniffer/view.cgi?url=http%3A%2F%2Frmp.ru%2Fcatalog%2Fsong.phtml%3Fid%3D50531&verbose=on

Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0CRLF

I didn't look at this too carefully, but I'm going to trust Daniel here.
Status: RESOLVED → VERIFIED
QA Contact: tever → httpqa
You need to log in before you can comment on or make changes to this bug.