Closed Bug 1755323 Opened 3 months ago Closed 3 months ago

Contextual menu for selecting spell check language not working on Wayland

Categories

(Core :: Widget: Gtk, defect, P3)

Firefox 97
defect

Tracking

()

RESOLVED FIXED
99 Branch
Tracking Status
firefox99 --- fixed

People

(Reporter: manuel.deljesuspe, Assigned: stransky, NeedInfo)

References

(Blocks 1 open bug)

Details

Attachments

(4 files)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:97.0) Gecko/20100101 Firefox/97.0

Steps to reproduce:

  1. Open Firefox in linux Gnome Wayland
  2. Navigate to a webpage with a text input area
  3. Right click on the area and try to change the spell language
  4. The selection list quickly flickers and it is impossible to select anything as it inmediately dissapears.

Actual results:

The spell checker language cannot be selected. It works perfectly well if Firefox is opened in an Xorg session

Expected results:

The contextual menu should extend and allow to select the desired language for the spell checker.

The Bugbug bot thinks this bug should belong to the 'Core::Widget: Gtk' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core

Thanks.

Flags: needinfo?(manuel.deljesuspe)
Priority: -- → P3

Also which Fedora do you use? And is that a regression, i.e. did it worked before on Wayland?

Attached file Compressed firefox log

I took a log while firefox was producing the reported error. I compressed it because it was quite a big file.

Flags: needinfo?(manuel.deljesuspe)

This is a small video where the problem can be seen.

I am using Fedora 35 and this is my first time using Fedora and Wayland. Before I had been using Pop_OS and Xorg, so I cannot know if this is a regression or if this problem was always there. The only thing that I know is that I use Xorg because there it works and I need to be changing dictionaries often. The problem with Firefox in Xorg is that it only opens about half the times it is invoked (I opened another issue for that).

Wow, you have quite a lot of dictionaries installed, which probably explains why I couldn't repro this at first... Probably we're trying to fit that on screen, and it's not scrollable, and stuff seems to fall apart...

The dictionaries are there because of hunspell and the LaTeX distribution. It is even uncomfortable to work with it, because, as you may imagine, I change dictionaries a lot, but I only use three... The thing is that in Xorg there is no problem whatsoever, it properly displays and lets me scroll the whole list. That is why I specified the issue happened only in Wayland.

Please, do not hesitate to ask for as many tests -in Xorg and Wayland- as you may require to diagnose the situation.

Thank you very much for your help

Please create 'widget.use-move-to-rect' a new bool key at about:config, set it to false and restart browser. Does it help?

Flags: needinfo?(manuel.deljesuspe)

It helps in the sense that the menu opens and stays; it is readable and selectable. However, the menu opens from the position of the Language option in the contextual menu to the bottom of the page. This forces most languages to appear out of the screen, and thus, turns most languages into effectively non selectable, since the menu that opens cannot be explored up and down with the mouse.

May I do some additional test that may give some additional information?

Flags: needinfo?(manuel.deljesuspe)

Yes, this is endless loop of resizing caused by move-to-rect calls.

Assignee: nobody → stransky
Status: UNCONFIRMED → NEW
Ever confirmed: true

I cannot get that build to load all of my dictionaries. It only loads the default one, that seems to open flawlessly (I mean, it draws the selection menu without any apparent issue), but I cannot verify if it works with my full list of dictionaries.

How may I inform that build of where to look for my system dictionaries? My default Firefox seems to find them without any action on my side.

Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/1fd96fdf0f2e
[Wayland] Added widget.wayland.use-move-to-rect preference to control popup placement r=emilio
https://hg.mozilla.org/integration/autoland/rev/b2b38f41ccbc
[Wayland] Use plain move to position popup if move-to-rect changed popup position r=emilio
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 99 Branch
Flags: qe-verify+
Regressions: 1759157
Blocks: 1758594
No longer regressions: 1759157
You need to log in before you can comment on or make changes to this bug.