Phoenix does not work with CDRWin5 ASPI drivers

VERIFIED WORKSFORME

Status

()

Firefox
General
--
critical
VERIFIED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Pau Garcia i Quiles, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When CDRWin 5 (http://www.cdrwin.info) installs, it upgrades the ASPI drivers. 

When these ASPI drivers are installed, Phoenix 0.3 does not work (the program
appears as a process in the task manager, but you cannot see or use it).

As of 20021019 nightly build, the bug is open.

Comment 1

16 years ago
It is highly unlikely that the installation of new ASPI drivers could affect
Phoenix. Phoenix certainly doesn't use them in any way.

Comment 2

16 years ago
While unable to test this bug (as I have Win2K and not WinXP), I must second
Andre's gut reaction.  Having worked extensively with ASPI layers (as an Adaptec
and later a Roxio employee) there is pretty much no way that ASPI drivers could
be responsible.

To pgq (reporter), CDRWin doesn't "upgrade" the ASPI drivers as WinXP no longer
ships with or requires an ASPI layer.  Win2K and WinXP now use the
Microsoft-created SPTI (SCSI Pass-Through Interface) natively and only require
ASPI drivers for programs that make ASPI calls.  Thus CDRWin "installs" an ASPI
layer under WinXP.

Be that as it may, I suggest you try uninstalling CDRWin and its ASPI layer to
see if this corrects the problem.  If it does not it was likely not the cause. 
If removing CDRWin DOES correct the issue, try using the Adaptec ASPI layer,
since Adaptec wrote ASPI in the first place.

The Adaptec ASPI layer can be found at:

http://www.adaptec.com/worldwide/support/drivers_by_product.html?sess=no&cat=%2fProduct%2fASPI-4.70&prodkey=ASPI-4.70

Also, I have always been familiar with CDRWin as a product of Golden Hawk
Technology, whose page can be found at http://www.goldenhawk.com/ and not at
http://www.cdrwin.info (which redirects to www.disc4you.de).  The Golden Hawk
website shows the latest version as 3.9B, not 5.o, although this could be a US
vs. International release version issue.

If uninstalling CDRWin or replacing the CDRWin ASPI drivers with Adaptec's
version solves the issue, you have probably shown that the ASPI drivers WERE the
cause.  If these do not solve the issue, then Andre's reaction is probably
correct and the problem lies elsewhere.
(Reporter)

Comment 3

16 years ago
I've already tested what Andy H. suggests: if you tell CDRWin 3.9 (or 5) not to
install the ASPI layer, Phoenix works.

If you let CDRWin install the ASPI drivers, then Phoenix does not start: Windows
loads it, but you cannot use it.

Later, if you uninstall the ASPI layer that CDRWin installs, Phoenix works again.

I've only tested this with Windows XP Pro, not Win2K or earlier.

Comment 4

16 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021019
Phoenix/0.3

I can't confirm this on my Windows XP box. I went to goldenhawk.com, and
downloaded then installed their ASPI drivers. I quit Phoenix, then restarted.
Works fine. Starts up normally. No abnormal behavior, which is good because I
can't figure out how to install those files.

Comment 5

16 years ago
On previous post, I meant "uninstall" those drivers. Anyway, I decided to go
ahead and install the whole package of CDRWin 3.9 beta with the aforementioned
ASPI drivers. Still behaves normally.
(Reporter)

Comment 6

16 years ago
I've tested Phoenix 20021020 with Win2K Pro and CDRWin5 and it works. I don't
know why Phoenix + CDRWin5 + WinXP Pro does not work :-?

Comment 7

15 years ago
Pau, I'm sorry bug this bug must be related to your system in some way. This bug
is not going anywhere, so I'm marking it WORKSFORME based on other people's tests.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 8

15 years ago
VERIFIED Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030721
Mozilla Firebird/0.6
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.