make newsgroups show abbreviated names in folder tree.

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: scottputterman, Assigned: scottputterman)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

18 years ago
I couldn't find a bug for this already so I'm creating a new one.  Currently,
the folder pane shows newsgroups with their full names.  Instead we can
conserve space by showing the abbreviated name.  I have a fix in my tree for
this.  I basically just hooked up our datasource to a new folder method called
GetAbbreviatedName and I hooked up code that already did this in
nsNewsFolder.cpp.

There's a pref "news.abbreviate_pretty_name" that tells how many words from the
right should be abbreviated.  Right now if you don't want anything abbreviated,
set this to some really high value.

Eventually we'll have a tool tip that shows the full name of the newsgroup.

To clarify,

netscape.public.mozilla.mail-news will now show up as n.p.m.mail-news in order
to save space.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Updated

18 years ago
QA Contact: lchiang → huang

Comment 1

18 years ago
Is this the bug?  http://bugzilla.mozilla.org/show_bug.cgi?id=11044

Comment 2

18 years ago
If so, can you mark the other bug as a duplicate of this one?
*** Bug 11044 has been marked as a duplicate of this bug. ***
cool, Oleg's code is finally getting used.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 5

18 years ago
Passed by retest on Linux 11-04-08-M11,
Mac 11-04-08-M11 and WinNT 11-04-09-M11  All platforms passed!
Mark as Verified
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.