Closed Bug 1755681 Opened 2 years ago Closed 2 years ago

[UK][amazon.co.uk] The autofill dropdown is not triggered and the autofill functionality is not working for the PostCode field

Categories

(Toolkit :: Form Autofill, defect, P2)

Desktop
All
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox97 --- disabled
firefox98 --- disabled
firefox99 --- disabled

People

(Reporter: sbadau, Unassigned)

References

(Blocks 2 open bugs, )

Details

Attachments

(3 files)

Affected Versions:

Nightly 99.a1, Beta 98 and Release 97

Tested on:

MacOS 11
Windows 10

Preconditions:

browser.search.region GB
extensions.formautofill.addresses.enabled - true
extensions.formautofill.addresses.supported to "detect"
extensions.formautofill.addresses.supportedCountries US,CA,GB

download latest Firefox Nightly with region locale
have a complete address already saved in about:preferences#privacy

Steps to reproduce:

  1. Reach the address form on amazon.co.uk
  2. Click in the Full Name field and using the autofill feature, select 1 saved address entry.
  3. Click in the Postcode field.

Expected Results:

  1. All the fields should be successfully auto-filled.
  2. The address autofill dropdown should be displayed for all the fields.

Actual Results:

  1. The Postcode field is not autofilled.
  2. The address autofill dropdown is not displayed for the Postcode field.

Notes:

  1. Reproducible on Chrome: No

Resetting the Priority bug as was accidentally set.

Priority: P3 → --
Priority: -- → P2
Assignee: nobody → tgiles

Simona, I tried to reproduce but it seems like I'm unable to get the address autofill dropdown to appear at all now. Address autofill is working for the test page but I just want to make sure it's nothing something with my environment. Are you able to reproduce this issue?

Flags: needinfo?(simona.marcu)

Tim, the issue is still reproducible for me - re-tested on the latest Nightly 100.0a1 on macOS Big Sur 11.6. Please see the screencast.

Flags: needinfo?(simona.marcu) → needinfo?(tgiles)
Attached image image.png

Thanks for that Simona! My issue was that I was trying to use browser.search.region = UK instead of browser.search.region = GB so my autofill wasn't working correctly. After fixing that, I am able to reproduce the original issue.

As highlighted in the attached screenshot, Amazon has set the postcode field's autocomplete attribute to off. Since they have set autocomplete off, we cannot currently fill this field as we respect the attribute. This is something that could be resolved by Bug 1754879

Flags: needinfo?(tgiles)
Assignee: tgiles → nobody

Closing as resolved: Worksforme since the issue isn't reproducible anymore.
Tested on Windows 10 x64, macOS 11.6 using the latest Nightly 104.0a1, Beta 103.0b2 and Firefox 102.0.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.