Phoenix crashes when deleting yahoo mail.

VERIFIED WORKSFORME

Status

()

Core
HTML: Form Submission
P3
normal
VERIFIED WORKSFORME
15 years ago
15 years ago

People

(Reporter: cartman, Assigned: Stephane Saux)

Tracking

({crash})

Trunk
mozilla1.0.3
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
I am trying to delete my yahoo mail and phoenix crashes. This crash randomly
happens when I use submit buttons. Here is the backtrace I got :

Build Number 20021012

#0  0x4095d681 in DummyParserRequest::GetURI(nsIURI**) () from
/home/cartman/phoenix/components/libgkcontent.so
#1  0x40ca7108 in nsSecureBrowserUIImpl::OnStateChange(nsIWebProgress*,
nsIRequest*, unsigned, unsigned) ()
   from /home/cartman/phoenix/components/libpipboot.so
#2  0x40ef03e9 in nsDocLoaderImpl::FireOnStateChange(nsIWebProgress*,
nsIRequest*, int, unsigned) ()
   from /home/cartman/phoenix/components/liburiloader.so
#3  0x40eef232 in nsDocLoaderImpl::OnStartRequest(nsIRequest*, nsISupports*) ()
   from /home/cartman/phoenix/components/liburiloader.so
#4  0x40797ce0 in nsLoadGroup::AddRequest(nsIRequest*, nsISupports*) () from
/home/cartman/phoenix/components/libnecko.so
#5  0x4095c3ad in HTMLContentSink::AddDummyParserRequest() () from
/home/cartman/phoenix/components/libgkcontent.so
#6  0x40953528 in HTMLContentSink::WillBuildModel() () from
/home/cartman/phoenix/components/libgkcontent.so
#7  0x40dc5a94 in CNavDTD::WillBuildModel(CParserContext const&, nsITokenizer*,
nsIContentSink*) ()
   from /home/cartman/phoenix/components/libhtmlpars.so
#8  0x40ddc7bf in nsParser::WillBuildModel(nsString&) () from
/home/cartman/phoenix/components/libhtmlpars.so
#9  0x40dddb5e in nsParser::ResumeParse(int, int, int) () from
/home/cartman/phoenix/components/libhtmlpars.so
#10 0x40ddec45 in nsParser::OnDataAvailable(nsIRequest*, nsISupports*,
nsIInputStream*, unsigned, unsigned) ()
   from /home/cartman/phoenix/components/libhtmlpars.so
#11 0x40eeb39d in nsDocumentOpenInfo::OnDataAvailable(nsIRequest*, nsISupports*,
nsIInputStream*, unsigned, unsigned) ()
   from /home/cartman/phoenix/components/liburiloader.so
#12 0x407d5a17 in nsHTTPCompressConv::do_OnDataAvailable(nsIRequest*,
nsISupports*, unsigned, char*, unsigned) ()
   from /home/cartman/phoenix/components/libnecko.so
#13 0x407d563f in nsHTTPCompressConv::OnDataAvailable(nsIRequest*, nsISupports*,
nsIInputStream*, unsigned, unsigned) ()
   from /home/cartman/phoenix/components/libnecko.so
#14 0x407b66d2 in nsStreamListenerTee::OnDataAvailable(nsIRequest*,
nsISupports*, nsIInputStream*, unsigned, unsigned) ()
   from /home/cartman/phoenix/components/libnecko.so
#15 0x407fa677 in nsHttpChannel::OnDataAvailable(nsIRequest*, nsISupports*,
nsIInputStream*, unsigned, unsigned) ()
   from /home/cartman/phoenix/components/libnecko.so
#16 0x407b5a21 in nsOnDataAvailableEvent::HandleEvent() () from
/home/cartman/phoenix/components/libnecko.so
#17 0x4079d219 in nsARequestObserverEvent::HandlePLEvent(PLEvent*) () from
/home/cartman/phoenix/components/libnecko.so
#18 0x40177b77 in PL_HandleEvent () from /home/cartman/phoenix/libxpcom.so
#19 0x40177b04 in PL_ProcessPendingEvents () from /home/cartman/phoenix/libxpcom.so
#20 0x40179adb in nsEventQueueImpl::ProcessPendingEvents() () from
/home/cartman/phoenix/libxpcom.so
#21 0x40c26d15 in event_processor_callback(void*, int, GdkInputCondition) ()
   from /home/cartman/phoenix/components/libwidget_gtk.so
#22 0x40c26c9d in our_gdk_io_invoke(_GIOChannel*, GIOCondition, void*) ()
   from /home/cartman/phoenix/components/libwidget_gtk.so
#23 0x403a9c40 in g_io_unix_dispatch (source_data=0x8290c50,
current_time=0xbffff520, user_data=0x8290c28) at giounix.c:135
#24 0x403ab308 in g_main_dispatch (dispatch_time=0xbffff520) at gmain.c:656
#25 0x403ab913 in g_main_iterate (block=1, dispatch=1) at gmain.c:877
#26 0x403abaac in g_main_run (loop=0x8290cc8) at gmain.c:935
#27 0x402bb379 in gtk_main () from /usr/local/lib/libgtk-1.2.so.0
#28 0x40c26876 in nsAppShell::Run() () from
/home/cartman/phoenix/components/libwidget_gtk.so
#29 0x40c0a414 in nsAppShellService::Run() () from
/home/cartman/phoenix/components/libnsappshell.so
---Type <return> to continue, or q <return> to quit---
#30 0x0804f4a1 in main1(int, char**, nsISupports*, nsXREAppData const&) ()
#31 0x0804e685 in xre_main(int, char**, nsXREAppData const&) ()
#32 0x0804e11e in main ()
#33 0x40578522 in __libc_start_main (main=0x804e080 <main>, argc=1,
ubp_av=0xbffff8b4, init=0x804d500 <_init>,
    fini=0x4001558c <_dl_debug_mask>, rtld_fini=0xbfffed00, stack_end=0x0) at
../sysdeps/generic/libc-start.c:129


P.S: If this is a mozilla bug please change product accordingly

Comment 1

15 years ago
is this a dup of bug 161538?

Comment 2

15 years ago
Yahoo's been crashing on me randomly in the past few days due to a terrible java
commercial they are displaying. The add banner I'm talking about is black and
white with people dancing on it. The commercial also has sound. Was that
commercial present at the time of your crash?

FYI: I'm using JRE 1.4.1 on Win XP.
(Reporter)

Comment 3

15 years ago
I have no Java installed here so this is completely a different problem imho

Comment 4

15 years ago
Looks like a crash in security somewhere. over to PSM
Assignee: blaker → ssaux
Status: UNCONFIRMED → NEW
Component: General → Client Library
Ever confirmed: true
Product: Phoenix → PSM
QA Contact: asa → junruh

Comment 5

15 years ago
This doesn't appear to be PSM related, just because the user decided to install
phoenix in a directory called /home/cartman. The crashes in http://climate -
http://climate/reports/VeryFastSearchStackSigNEW.cfm?stacksig=DummyParserRequest
generally show that the crash occurs when submitting a form.
Component: Client Library → Form Submission
Product: PSM → Browser
Version: unspecified → other

Comment 6

15 years ago
does it crash in Mozilla? if not, please get some of the Phoenix guys to look at.
Keywords: crash
Priority: -- → P3
Target Milestone: --- → mozilla1.0.3
(Reporter)

Comment 7

15 years ago
Yes Mozilla crashes too with same backtrace.

Comment 8

15 years ago
Works for me. The DummyParserRequest crashes have stopped with the 2002113012 build.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 9

15 years ago
Verified WFM.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.