Closed Bug 175596 Opened 19 years ago Closed 19 years ago

caret moves silently from current tab to a new one

Categories

(SeaMonkey :: Tabbed Browser, defect)

x86
Linux
defect
Not set
major

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 124750

People

(Reporter: mozi, Assigned: jag+mozilla)

Details

(Whiteboard: DUPEME)

User-Agent:       Mozilla/3.01Gold (Macintosh; I; 68K)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

(no details)

Reproducible: Always

Steps to Reproduce:
1.Open a page with some form to complete (for instance a login page)
2.Open another tab with another form, say google.com
3.quickly switch back to the first tab, and type something in the text form

Actual Results:  
when the page in the other tab has finished downloading, what you type
goes there, even if you're still seing the page of the first tab.
(i.e. the carret moves silently from the current tab to the hidden tab)

Expected Results:  
The caret should stay on the current tab, and what I type should 
always go to the visible tab.

I set the severity to major, since what you type could be a password,
and would appear and be readable when you switch the tab
(someone could read it).
We seem to have the same problem with the url bar :
the caret moves silently to the hidden tab when the corresponding
page (with a form) has finished downloading.
Summary: caret move silently from current tab to a new one → caret moves silently from current tab to a new one
Whiteboard: DUPEME
I don't see this. typeahead grabs the input if I switch between tabs for me
(Using mozilla 1.2a Linux 2002101612). I haven't tried it with typeahead
disabled though.

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.