Closed Bug 1756411 Opened 9 months ago Closed 8 months ago

[wpt-sync] Sync PR 32924 - Ensure backdrop filter cc::Layers are marked as drawing content

Categories

(Core :: Web Painting, task, P4)

task

Tracking

()

RESOLVED FIXED
100 Branch
Tracking Status
firefox100 --- fixed

People

(Reporter: mozilla.org, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 32924 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/32924
Details from upstream follow.

Xianzhu Wang <wangxianzhu@chromium.org> wrote:

Ensure backdrop filter cc::Layers are marked as drawing content

ContentLayerClientImpl::UpdateCcPictureLayer needs to set
cc::Layer::DrawsContent to true for content under a backdrop filter.
The previous code would do this based on the PendingLayer's effect node,
but this is incorrect if a single object has both a backdrop filter
effect node and a filter effect node. This approach failed to re-run
UpdateCcPictureLayer when HasBackdropEffect changed (see new WPT test
repaint-added-backdrop-filter.html).

This patch forces draws-content of all PendingLayers under an effect
node needing draws-content.

This patch is based on pdr@'s crrev.com/c/3367277. That patch uses
ScopedForceDrawsContent during painting and forces draws content flag
of PaintChunks. The problem is that we need to repaint the subtree of
an effect node on change of the node's MayDrawContent() status.

Bug: 1273849
Change-Id: Ie49d40c37767265e45278cf89ddf032895b9e832
Reviewed-on: https://chromium-review.googlesource.com/3474495
WPT-Export-Revision: 31f7de3ae352378746a328750d362aa277b62a5e

Component: web-platform-tests → Web Painting
Product: Testing → Core

CI Results

Ran 0 Firefox configurations based on mozilla-central, and Firefox, Chrome, and Safari on GitHub CI

Total 2 tests

Status Summary

Firefox

FAIL: 2

Chrome

FAIL: 2

Safari

FAIL: 2

Links

GitHub PR Head
GitHub PR Base

Details

New Tests That Don't Pass

/css/filter-effects/backdrop-filter-plus-will-change-opacity.html: FAIL (Chrome: FAIL, Safari: FAIL)
/css/filter-effects/repaint-added-backdrop-filter.html: FAIL (Chrome: FAIL, Safari: FAIL)

Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b5e77b3dd5fb
[wpt PR 32924] - Ensure backdrop filter cc::Layers are marked as drawing content, a=testonly
https://hg.mozilla.org/integration/autoland/rev/75358e5c70a1
[wpt PR 32924] - Update wpt metadata, a=testonly
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 100 Branch
You need to log in before you can comment on or make changes to this bug.