Closed Bug 1756538 Opened 7 months ago Closed 7 months ago

Include the dynamic thread priority on Windows 'Awake' markers

Categories

(Core :: Gecko Profiler, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
99 Branch
Tracking Status
firefox99 --- fixed

People

(Reporter: florian, Assigned: florian)

References

Details

Attachments

(1 file)

Windows boosts thread priorities (https://docs.microsoft.com/en-us/windows/win32/procthread/priority-boosts) based on undocumented algorithms (but the fact that a window receiving events gets a boost is clear).

This causes unexpected complications for us because the parent process gets a boost, making it have a higher priority than the GPU process and content process, that the parent is waiting for.

Seeing the actual current dynamic thread priority in the profiler may help us find solutions to cases where the process we are waiting on doesn't get scheduled on machines with few cores.

Severity: -- → N/A
Priority: -- → P3
Pushed by fqueze@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c4a4d283faa3
Include the dynamic thread priority in 'Awake' markers on Windows, r=gerald.
Regressions: 1756634
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 99 Branch
You need to log in before you can comment on or make changes to this bug.