[DOGFOOD] Pressing <ENTER> key in Dialogues should equate to OK button

VERIFIED FIXED in M13

Status

()

Core
XUL
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Paul MacQuiddy, Assigned: hangas)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-]RN may be fixed with other dialog fixes)

(Reporter)

Description

18 years ago
In many dialogues, there is an expectation that pressing Enter should be the
same as hitting the OK button. The wallet dialogues are one example of this. Let
me know if you need a list of dialogues.

To reproduce:

1. Goto Edit | Wallet | Change Password...
2. Type in a password and press <Enter>

Results: Nothing happens
Expected Results: Should act as if you pressed OK button

This is seen on all platforms 10/28 builds, and has been around since day 1.

I see this working on File - Open Web Location and File - Open but not on other
dialogs.

Updated

18 years ago
Assignee: davidm → sdagley

Comment 1

18 years ago
reassign to sdagley since this isn't working in any dialog ( alert or one with an
editfield). I am guessing something about our keybinding strategy has changed
since steve implemented his code. I think ender still sucks up metachars in
editfields so this bug might have to be reassigned before it is completely fixed.
The way that the Open Web Location works is a hack and should not be proprogated
IMNHO.

Comment 2

18 years ago
The same sort of expectation exists for using the [ESC] key to get the
effect of clicking on the [Cancel] button. Support for this is also
spotty at present.

Updated

18 years ago
Summary: Pressing <ENTER> key in Dialogues should equate to OK button → [DOGFOOD] Pressing <ENTER> key in Dialogues should equate to OK button

Comment 3

18 years ago
Adding lchiang, scalkins,prass and amusil to CC as this affects IM team. Setting
to Dogfood for PDT review. It is very annoying to have to click on the OK button
when users are accustomed to the Enter key doing the same job in dialog boxes.

Comment 4

18 years ago
There are probably 2 different problems:

1) Keybinding is apparently flaky at the moment (although saari sez waterson's
checkin today may have addressed the major issues)

2) Many dialogs are not using Paul Hangas' dialog template which provides for
platform specific button placement and dialog default buttons

Updated

18 years ago
Whiteboard: [PDT-]RN

Comment 5

18 years ago
Putting on PDT- radar.  Fix not needed for dogfood.

Updated

18 years ago
Status: NEW → ASSIGNED

Updated

18 years ago
Component: HTML Dialogs → XP Toolkit/Widgets

Comment 6

18 years ago
moving to xptoolkit so HTML dialogs component can be retired.

Updated

18 years ago
Target Milestone: M13

Comment 7

18 years ago
targetting p3 for m13

Comment 8

18 years ago
*** Bug 15852 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Assignee: sdagley → hangas
Status: ASSIGNED → NEW

Comment 9

18 years ago
Hangas asked for key behavior in dialog bugs to be sent his way...
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Whiteboard: [PDT-]RN → [PDT-]RN may be fixed with other dialog fixes

Comment 10

18 years ago
<ENTER> is equating to the [OK] button in the "Open Web Location" and "Open
File" Dialogs, using the 1999-12-23-08-M13 nightly binary on Windows NT 4.0sp3
This may be no surprise given the contents of the Status Whiteboard.

Comment 11

18 years ago
This is not working for authentication dialogs (http://is).
spam: adding self to cc list, as this does affect some of my areas.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

18 years ago
This bug is actually a duplicate of another bug that has been fixed.  Marking
this one fixed.  If there are still dialogs that have this problem please file
one bug for each dialog.

Updated

18 years ago
QA Contact: cpratt → sairuh
verif.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.