Website constantly reloads itself

VERIFIED INVALID

Status

()

Firefox
General
VERIFIED INVALID
15 years ago
13 years ago

People

(Reporter: Ryan Polk (Quark), Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021020 Phoenix/0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021020 Phoenix/0.3

NFL.com's website continuously reloads itself, making it near impossible to do
anything on it.

I've had this occur to me on 0.3 and on the latest nightly (downloaded just now,
early in the 10/21 morning EST).

Not definate, but this MAY have been happening to me on the latest Linux build too.

The bug doesn't occur in Mozilla 1.2b (and didn't for previous builds of Mozilla
I used, 1.2a, 1.1b, and 1.1 included).

If I open a new tab (ctrl-T shortcut) while viewing the webpage, it will stop
reloading itself until I perform certain other functions with tabs (it mostly
starts re-occuring when I close the newly opened tab).

As an addendum, I do remember the home page of nfl.com reloading itself whenever
I would middle-click a link to open a new tab on ALL versions of Mozilla.  That
may or may not be related.

Reproducible: Always

Steps to Reproduce:
1. go to http://www.nfl.com



Actual Results:  
Page constantly reloaded

Expected Results:  
Stopped after first load.

Using Tabbrowser Extensions

Comment 1

15 years ago
this page works fine for me.  no apparent 'reloading' and I am able to use the
site fine.

10/20 linux build

Comment 2

15 years ago
I can't confirm this with the 10/20/2002 W2k build.

Reporter, did you install your phoenix build into a clean directory and deleted
your old profile as suggested in the release notes? Did this also occur without
Tabbrowser Extensions being installed?

Comment 3

15 years ago
I can't reproduce this fault as described, but the site is installing
a JavaScript resize handler when first loaded.  When triggered this
handler checks to see if the page has changed size (using
window.innerWidth and window.innerHeight) and if so reloads it.
Perhaps this is related to what you were seeing?

Note that IE 6 doesn't reload the page as it doesn't seem to know
about window.innerWidth or window.innerHeight.


steve.

Comment 4

15 years ago
If I resize the page it reloads itself for me with a Phoenix build from
yesterday on Linux, but it doesn't do it automatically. WFM.
(Reporter)

Comment 5

15 years ago
Figured it out.  It's a combination of Phoenix and the theming program
'StyleXP'.  The theme I had installed had a slightly larger-than-normal status
bar, which was forcing the 'resize' reload.

Comment 6

15 years ago
Reloads if window is resized, even when loaded in new tab in the background. 
Reloads if sidebar is opened or closed.  It's annoying.  Could this possibly be
handled by the pref that blocks Javascript from resizing or moving windows?  

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021020 Phoenix/0.3,
build 2002102008

Comment 7

15 years ago
The site reloads when resizing, as coded. This is not a problem with Phoenix.

if(!window.saveInnerWidth) {
  window.onresize = resize;
  window.saveInnerWidth = window.innerWidth;
  window.saveInnerHeight = window.innerHeight;
}
function resize() {
    if (saveInnerWidth < window.innerWidth || saveInnerWidth > window.innerWidth
|| saveInnerHeight > window.innerHeight || saveInnerHeight < window.innerHeight ) {
	        window.history.go(0); // RELOAD
    		}
		}


Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 8

15 years ago
This bug is occuring at the web site http://www.washingtonpost.com/ with both
Phoenix 0.4 and the Phoenix 11-13-2002 nightly build but not Mozilla.  To
reproduce this bug:

1. Go to http://www.washingtonpost.com/
2. Click a link (e.g.
http://www.washingtonpost.com/wp-dyn/articles/A51437-2002Nov13.html)
3. Fill out the question form and click Go.
4. Go to the News Home Page by clicking the News Home Page link in the top left
corner (http://www.washingtonpost.com/wp-srv/front.htm)
5. Click another story link (e.g.  D.C. Group Eyes Baseball Team at
http://www.washingtonpost.com/wp-dyn/articles/A51184-2002Nov13.html)
6. Click "Nation" link (http://www.washingtonpost.com/wp-dyn/nation)
7. Click another story.

This can also occur if you click the back then forward buttons after step #5

Comment 9

15 years ago
*** Bug 200270 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
Basically, I think this should not be marked invalid and should be reopened, or
marked as wontfix, which would be a shame. This bug has annoyed me for months
and I thought it was a bug in Phoenix or Gecko. I didn't even know how to fix it.

There may be helpful information in 200270, but mostly only which theme I used
to cause the error. The reporter of this bug says that its the status bar, which
definately seems plausable. It doesnt happen in Moz, and Moz doesn't use the
Windows theme's status bar.

This could happen for users of both StyleXP and WindowBlinds, among potential
other users. Note that WindowBlinds works for all OS's. Also, If Phoenix follows
the WM settings in Linux, how does it handle that? Is it OK? If so, why is it OK
there and not in Windows?
(Reporter)

Comment 11

15 years ago
Well, as I said on the MozillaZine forums when this topic came up again, I'm
definatly open to someone else re-opening the bug and confirming it for the
latest builds.  I just won't do it myself as:
1)While on a nightly, I'm still using a slightly older version of Phoenix
2)Since changing my theme (and using the .dll hack instead of StyleXP) the
problem has gone away.  I was previously using the old chrome theme but now am
using chrome[4XP]2G (the second generation, I THINK it's spelled like that).  
3)While I don't agree with David Tenser's decision, it was his, and I'm a newbie.

So it's up to someone else who has more current data if they want to reopen this.

Comment 12

15 years ago
RE:1) Well, its still broken on current nightlies. ;)
RE:2) The dll hack doesnt work if you're running XP SP1, at least, not to my
knowledge. I think they moved the files or something. It definately is theme
dependant; I'm not sure what it is in the theme which sets it off.
Unfortunately, most users of Phoenix (including myself for 4+ months) have no
idea that this is what's causing this problem, so I think it needs to be
addressed. It also could possibly affect more people then just StyleXP (which
only works in WinXP) through such programs as WindowBlinds.
RE:3) I hope David Tenser just needs to be properly convinced. ;) But I also
haven't read the discussions on the forums...

Thanks for the vote. :) Lets hope to get a few more. It would obviously really
help if someone could do a proposed patch; unfortunately I know nothing about
Moz, it'd take me hours just to find where to start. :/
(Reporter)

Comment 13

15 years ago
Actually, I am using a .dll hack for XP SP1, though IIRC it was one specific to
the pack

Link to the discussion in the forum:
http://www.mozillazine.org/forums/viewtopic.php?t=6568

Comment 14

15 years ago
VERIFIED Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030714
Mozilla Firebird/0.6
Status: RESOLVED → VERIFIED

Comment 15

14 years ago
*** Bug 239751 has been marked as a duplicate of this bug. ***

Comment 16

13 years ago
see bug 258917 for the fix for broken sites which improperly caused reloads on
resize
You need to log in before you can comment on or make changes to this bug.