an absolutely positioned DIV followed by another absolutely positioned DIV, with a .png image .... the image is not visible

RESOLVED WORKSFORME

Status

()

P2
normal
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: bugs, Unassigned)

Tracking

({platform-parity, regression, testcase})

Trunk
Future
x86
Linux
platform-parity, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments, 3 obsolete attachments)

(Reporter)

Description

16 years ago
When the page is first loaded, the text appears black on black.  Selecting the
text, however, then deselecting it, leaves a grey background - which is actually
the colour of the background image he decided to use for some odd reason.
(actually, probably to make things easier on browsers unable to do a
semi-transparent alpha channel effects - hm. I wonder if mozilla can do them)

Might be similar to bug 163677 - filed anyway since his page seems to work for me.

Comment 1

16 years ago
See the attached reduced testcase.

The 1st DIV has a style :- 
        color: white; position: absolute; top: 75px; 
The 2nd DIV has a style :- 
        background-image: url('http://cun.niling.us/images/tint.png');
        border : thick solid red ;
  	position: absolute;
  	left: 200px;
  	right: 100px;
  	top: 200px;


what do i see:-
if an absolutely positioned DIV is followed be another absolutely positioned DIV
with a .png image .... the image is not visible.
***This is only occuring on Linux***

changing summary... 
Keywords: testcase
Priority: -- → P3
Summary: Background image in div.Body not initially displayed. → an absolutely positioned DIV followed be another absolutely positioned DIV, with a .png image .... the image is not visible

Comment 2

16 years ago
Created attachment 103603 [details]
minimized testcase

see comment 1
worksforme on windows 2000, build 2002101908.
Keywords: pp

Comment 4

16 years ago
i have stated in comment 1 that this bug is only reproducible on Linux.

I tested this on Red Hat Linux 7.2 build 2002-10-18-08trunk
I haven't had a chance to look at this, but ->Views, and cc:tor since linux-only.

However, I'm on Linux, and I'm seeing a gray background inside the red border,
which makes me think that I'm not seeing the bug.
Assignee: dbaron → roc+moz
Component: Style System → Views
Priority: P3 → --
QA Contact: ian → petersen
Summary: an absolutely positioned DIV followed be another absolutely positioned DIV, with a .png image .... the image is not visible → an absolutely positioned DIV followed by another absolutely positioned DIV, with a .png image .... the image is not visible
The 'minized testcase' works fine for me, but the original page does not work.
Ah, the minimized testcase does fail. Here's the secret: if and only if you
generate an expose event that includes the 'Head' element AND the 'abs' element,
then the 'abs' element background is not painted.
Seems to work fine with other PNGs. Over to tor.
Assignee: roc+moz → tor

Comment 9

16 years ago
For some reason the testcase doesn't appear to be able to retrieve the
backgroung png image now (maybe website is blocking other pages' using of their
images)- you might want to save testcase locally to test it(this seems to work
just fine)

Comment 10

16 years ago
Created attachment 103761 [details]
another testcase showing the PNG image is retrievable

In this testcase, I have included another DIV, which has "position:fixed".
This DIV displays the PNG image ... thus showing that the image is retrievable
from the website.

Comment 11

16 years ago
Created attachment 103765 [details]
another testcase

this testcase is an alteration to attchment 103603 .....
Here i have removed the "positon : absolute ; top : 25px" style from the _1st_
DIV.

Now the PNG image is visible in the _2nd_  DIV.

Comment 12

16 years ago
So, now looking at the two attached testcases : attachment 103603 [details] and attachment
103765 , i will re-emphasis my summary 
"an absolutely positioned DIV  followed by another absolutely positioned DIV,
with a PNG image .... the image is not visible" 

looking at attachment 103761 [details] .... 
"an absolutely positioned DIV  followed by a fixed positioned DIV, with a PNG
image .... the image _is_ visible"

Comment 13

16 years ago
Sorry for the extra work Madhur- I can see the png within your first testcase
now with my Windows 2002101612 1.2b build- I had set my Preferences to not
accept images from outside sites- it was late at night and I forgot I did that
till just today.  Sorry again people- I'm an idiot.

Comment 14

16 years ago
actually, window 2000 has been showing the image all along.
It is "RedHat Linux 7.2" which does not _still_ show the image.

I still stand by my summary. This bug is a linux only bug, people! 
Please see the other 2 attached testcases as well...... and this time on a linux
platform, please. Thanks !

Comment 15

16 years ago
This is a regression. The testcases render fine on Netscape7.0 release. 
And the testcases fail on the 2002-10-22-08trunk build on the linux platform.

Adding KW : regression
Taking QA
Keywords: regression
Priority: -- → P2
QA Contact: petersen → madhur

Comment 16

16 years ago
->  Layout:R & A Pos.
Assignee: tor → position
Component: Views → Layout: R & A Pos
Priority: P2 → --
roc?  Is this a view problem or not?  (If things are in the right places but not
painting right this is the wrong component).
Re comment 14:  I was testing on Linux (Red Hat Linux 8.0), and I didn't see the
bug.  Or at least I don't think I did.  However, I'm not sure since there aren't
any clear descriptions of expected results vs. actual results, and I only looked
at the testcase very quickly.
I saw this bug on Linux.

On my setup the bug only manifests when I generate an expose event which
includes the 'Head' element AND the 'abs' element.

I suspect imglib because I don't have any problems when I substitute a different
PNG.

Difficulty of reproduction could indicate a use-of-uninitialized-variable or
similar.

Comment 20

16 years ago
the first and second testcases regressed between linux trunk builds 2002061108
and 2002061304

as far as expected / actual results:
1st testcase:
expected: grey background in the div with a red border
actual: black background

2nd testcase:
expected: grey background in both divs with a red border
actual: black background in first div w/ red border, grey background in second

3rd testcase:
expected: grey background in div
actual: grey background in div

also (and this is probably screwing people up), the background will be gray the
very first time you view it.  Further attempts to reproduce will always show up
black.  Disabling cache or setting cache size 0 does not help, but clearing the
cache fixes it once.
Andrew, those are early _June_ builds, right?  In that time period, the likely
culprits are bug 124685 (roc), paper's patches (bug 85595 and bug 148551, though
these should not affect background rendering, I would think), 
Bug 124685 only affects invalidation due to some change in the content. In this
bug the expose events are coming from the system.

Comment 23

16 years ago
> Andrew, those are early _June_ builds, right?

yep.  firing up old builds often appears to work, but reloading exposes the bug.

Comment 24

16 years ago
Thanks Andrew... i failed to mention in my previous comments that reloading the
page would expose the bug.

And here are the expected vs. actual results for all the 3 testcases :-
==========
Testcase 1 
==========
<style>
body {
  	background-color: black;
}
div.Head {
        color : white;
	position: absolute;
	top: 25px;
}
div.abs {
  	background-image: url('http://cun.niling.us/images/tint.png');
        border : thick solid red ;
        color : red;
  	position: absolute;
  	left: 200px;
  	right: 100px;
  	top: 200px;
} </style>

expected: 
the DIV with class="abs" should show the Gray PNG image within the red  border.
actual : 
the image is not visible
==========
Testcase 2
==========
<style>
body {
  	background-color: black;
}
div.Head {
        color : white;
	position: absolute;
	top: 25px;
}
div.abs {
  	background-image: url('http://cun.niling.us/images/tint.png');
        border : thick solid red ;
        color : red;
  	position: absolute;
  	left: 200px;
  	right: 100px;
  	top: 200px;
}
div.fix {
  	background-image: url('http://cun.niling.us/images/tint.png');
        border : thick solid red ;
        color : red;
  	position: fixed;
  	left: 200px;
  	right: 100px;
  	top: 400px;
} </style>

expected :
DIV with class="abs", as well as, the DIV with class="fix" should show the Gray
PNG image within the red  border.
actual : 
the image is not visible  within the DIV with class="abs".
image is visible within the DIV with class="fix"

==========
Testcase 3
==========
<style>
body {
  	background-color: black;
}
div.Head {
        color : white;
}
div.abs {
  	background-image: url('http://cun.niling.us/images/tint.png');
        border : thick solid red ;
        color : red;
  	position: absolute;
  	left: 200px;
  	right: 100px;
  	top: 200px;
} </style>

expected & actual :
the DIV with class="abs" should show the Gray PNG image within the red  border.

=======================================
(Reporter)

Comment 25

16 years ago
Nice set of testcases.
Yep.  Looks like linux only.  Thought the other guy I checked with in
#mozillazine was running windows.  Guess not.

And regarding a couple of comments, this isn't just RH bug.  Am using gentoo 1.4 rc1
gcc 3.2, gnome2, kde3

Updated

16 years ago
Priority: -- → P2

Updated

16 years ago
Target Milestone: --- → Future

Comment 26

16 years ago
Any hope of getting this fixed soon?  My site is completely blown up for Linux
users due to this bug.  I've been seeing this problem since before 1.2, and I
was really hoping it'd be fixed by 1.3.
Created attachment 129071 [details]
Corrected 1st testcase
Attachment #103603 - Attachment is obsolete: true
Created attachment 129072 [details]
Corrected 2nd testcase
Attachment #103761 - Attachment is obsolete: true
Created attachment 129073 [details]
Corrected 3rd testcase
Attachment #103765 - Attachment is obsolete: true
The original testcases use http://cun.niling.us/images/tint.png as background
image which does not exist anymore.  I have attached corrected testcases that
use the same bg image as on the site: http://cun.niling.us/style/default/tint

All (corrected) testcases and URL now works fine.

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.