Characters in bookmarked URLs should not be escaped or otherwise converted from the original URL.

RESOLVED INVALID

Status

SeaMonkey
Bookmarks & History
RESOLVED INVALID
16 years ago
14 years ago

People

(Reporter: Mike Morgan, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1b) Gecko/20020721
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1b) Gecko/20020721

When bookmarking a URL containing any of an apparently defined set of
characters, those characters will be converted to their HTML equivalents in the
bookmark, rendering the bookmark unusable.

Reproducible: Always

Steps to Reproduce:
1. Point browser to
http://heavens-above.com/main.asp?Loc=Richmond&Lat=37.554&Lng=-77.461&TZ=EST
(If the URL in your address bar shows any occurences of "amp", possibly Bugzilla
has an overexuberance of escaping characters... If so, stop troubleshooting now,
but read on.)
2. Bookmark that URL
3. Revisit the bookmark

Actual Results:  
All ampersands in the bookmarked webpage's URL were converted to their HTML-safe
equivalent, "&", in the bookmarked URL. This modification caused the
Heavens-Above website server to assume defaults for all variables after the
first confusedly converted ampersand in the requested, bookmarked URL. Most
noticably, the latitude and longitude of the request were then assumed by the
server to be 0 and 0, allowing it to calculate that I live on the equator, a
long swim west of the coast of Africa. This URL conversion caused the site's
normally exceedingly-precise simulations to be unusably incorrect.

Expected Results:  
Allow broken URLs.

Never escape ampersands in bookmarked URLs.
Characters in bookmarked URLs
should not be escaped or otherwise converted
from the original URL.

Allow broken URLs.

n.b. There are probably a few other characters in addition to the ampersand
which shouldn't be escaped in bookmarked URLs.
(Reporter)

Comment 1

16 years ago
This may be invalid, only be a problem with conversion from previous bookmarks...

However, after attempting to change all &'s several times
to &'s and having the bookmark manager reset those changes, I quit researching.

By the way, the URL works fine in Bugzilla... :)

Comment 2

16 years ago
this bug is related to 94651

Comment 3

16 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021014 Phoenix/0.3
wfm. tested:
dragging (bugzilla) "url" to bookmarks sidebar, clicking url there
deleting bookmark and dragging url proxy to bookmarks sidebar and clicking it.

Reporter: you're using mozilla1.1b, which should be considered unsupported.
please upgrade to one of: 1.1final, 1.2b, trunk, 1.2final (coming soon depending
on how long you wait) -- simply put, please don't use a beta for a product which
has already released a final.
Also not a problem with a current linux build...
(Reporter)

Comment 5

16 years ago
I'm closing bug, as INVALID, since it's apparently not reproducable on supported
versions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.