Mail server (MDaemon 6.0.7) crashed on delete many mails

RESOLVED INVALID

Status

MailNews Core
Networking: IMAP
--
major
RESOLVED INVALID
15 years ago
9 years ago

People

(Reporter: Gerrit Hannaert, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Upon deletion (moving to Trash on imap, in fact) of 2000-or-so mails in Mozilla 
1.2beta; the mail service on Windows 2000 terminates unexpectedly.

This is a snippet of the mail server log; if you need more please ask.

Mon 2002-10-21 10:45:47: [196:3860] 26 OK STORE completed
Mon 2002-10-21 10:45:54: [196:3860] 27 UID fetch 32247 (UID RFC822.SIZE BODY[])
Mon 2002-10-21 10:45:54: [196:3860] Sending FETCH response (not logged)...
Mon 2002-10-21 10:45:54: [196:3860] 27 OK FETCH completed
Mon 2002-10-21 10:46:05: [196:3860] 28 UID fetch 32250 (UID RFC822.SIZE BODY[])
Mon 2002-10-21 10:46:05: [196:3860] Sending FETCH response (not logged)...
Mon 2002-10-21 10:46:05: [196:3860] 28 OK FETCH completed
Mon 2002-10-21 10:46:14: [196:3860] 29 uid copy 
29499:29506,29508:29639,29641:29711,29713:29775,29777:30146,30148:30685,30687:30
966,30968:31671,31673:31788,31790:31927,31929:31958,31960:31971,31973:32028,3203
1:32042,32044:320
Mon 2002-10-21 10:46:34: [196:3860] 29 OK COPY completed
Mon 2002-10-21 10:46:34: [196:3860] 30 uid store 
29499:29506,29508:29639,29641:29711,29713:29775,29777:30146,30148:30685,30687:30
966,30968:31671,31673:31788,31790:31927,31929:31958,31960:31971,31973:32028,3203
1:32042,32044:32
Mon 2002-10-21 10:46:34: [196:3860] * 323 FETCH (UID 29499 FLAGS (\Deleted 
\Recent))
Mon 2002-10-21 10:46:34: [196:3860] * 324 FETCH (UID 29500 FLAGS (\Deleted 
\Recent))
Mon 2002-10-21 10:46:34: [196:3860] * 325 FETCH (UID 29501 FLAGS (\Deleted 
\Recent))
Mon 2002-10-21 10:46:34: [196:3860] * 326 FETCH (UID 29502 FLAGS (\Deleted 
\Recent))
...
<snip>
...
Mon 2002-10-21 10:46:35: [196:3860] * 2276 FETCH (UID 31452 FLAGS (\Deleted 
\Recent))
Mon 2002-10-21 10:46:36: [196:3860] Winsock Error 10035 Operation would block.
Mon 2002-10-21 10:46:36: [196:3860] Error writing to socket
Mon 2002-10-21 10:46:36: [196:3860] IMAP session abnormally terminated, 1531057 
bytes transferred!
Mon 2002-10-21 10:46:36: ----------

START Event Log / MDaemon PRO v6.0.7 R, all log information
-------------------------------------------------------------------------------
Event Time/Date             Event Description
-------------------------------------------------------------------------------
Mon 2002-10-21 10:50:07: [INIT] Building "EVERYONE" mailing lists for all 
domains
Mon 2002-10-21 10:50:07: [INIT] Initializing mail processor
Mon 2002-10-21 10:50:07: [INIT] Unlocking all mailboxes and mail queues

Perhaps this is related to my other IMAP Bug (#151791), perhaps it is not. It 
looks similar in that the request (?) appears chopped off at a certain length, 
but then again maybe it's just the logging.

I can provide an account for debugging purposes if required, but would limit 
the time for testing since this is a production server.
(Reporter)

Comment 1

15 years ago
The error does *not* occur in Netscape 4.78. This is the same log (move to 
trash) coming from _Netscape 4.78_.

Mon 2002-10-21 11:24:02: ---------- Partial transcript, remainder will follow.
Mon 2002-10-21 11:10:41: [804:41] Accepting IMAP connection from [10.1.3.228]
Mon 2002-10-21 11:10:41: [804:41] * OK cropdesign.com IMAP4rev1 MDaemon 6.0.7 
ready
Mon 2002-10-21 11:10:41: [804:41] 1 login "degerrit" ******
Mon 2002-10-21 11:10:41: [804:41] 1 OK LOGIN completed
Mon 2002-10-21 11:10:41: [804:41] 2 select "INBOX"
Mon 2002-10-21 11:10:41: [804:41] * FLAGS (\Seen \Answered \Flagged \Deleted 
\Draft \Recent)
Mon 2002-10-21 11:10:41: [804:41] * 3094 EXISTS
Mon 2002-10-21 11:10:41: [804:41] * 2831 RECENT
Mon 2002-10-21 11:10:41: [804:41] * OK [UNSEEN 7] first unseen
Mon 2002-10-21 11:10:41: [804:41] * OK [UIDVALIDITY 995037183] UIDs valid
Mon 2002-10-21 11:10:41: [804:41] * OK [PERMANENTFLAGS (\Seen \Answered 
\Flagged \Deleted \Draft)] .
Mon 2002-10-21 11:10:41: [804:41] 2 OK [READ-WRITE] SELECT completed
Mon 2002-10-21 11:10:41: [804:41] 3 UID fetch 1:* (FLAGS)
Mon 2002-10-21 11:10:41: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:10:41: [804:41] 3 OK FETCH completed
Mon 2002-10-21 11:10:42: [804:41] 4 UID fetch 32270 (UID RFC822.SIZE FLAGS 
BODY.PEEK[HEADER.FIELDS (From To Cc Subject Date Priority X-Priority Message-ID 
References Newsgroups Return-Receipt-To Disposition-Notification-To)])
Mon 2002-10-21 11:10:42: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:10:42: [804:41] 4 OK FETCH completed
Mon 2002-10-21 11:10:48: [804:41] 5 UID fetch 32266 (UID RFC822.SIZE BODY[])
Mon 2002-10-21 11:10:48: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:10:48: [804:41] 5 OK FETCH completed
Mon 2002-10-21 11:10:50: [804:41] 6 noop
Mon 2002-10-21 11:10:50: [804:41] 6 OK NOOP completed
Mon 2002-10-21 11:10:50: [804:41] 7 UID fetch 32271:* (FLAGS)
Mon 2002-10-21 11:10:50: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:10:50: [804:41] 7 OK FETCH completed
Mon 2002-10-21 11:10:54: [804:41] 8 uid store 32266 -Flags (\Seen)
Mon 2002-10-21 11:10:54: [804:41] * 3090 FETCH (UID 32266 FLAGS (\Recent))
Mon 2002-10-21 11:10:54: [804:41] 8 OK STORE completed
Mon 2002-10-21 11:10:57: [804:41] 9 UID fetch 32268 (BODYSTRUCTURE)
Mon 2002-10-21 11:10:57: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:10:57: [804:41] 9 OK FETCH completed
Mon 2002-10-21 11:10:57: [804:41] 10 UID fetch 32268 (UID RFC822.SIZE BODY[]
<0.8192>)
Mon 2002-10-21 11:10:57: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:10:57: [804:41] 10 OK FETCH completed
Mon 2002-10-21 11:10:57: [804:41] 11 UID fetch 32268 (UID RFC822.SIZE BODY[]
<8192.8192>)
Mon 2002-10-21 11:10:57: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:10:57: [804:41] 11 OK FETCH completed
Mon 2002-10-21 11:10:57: [804:41] 12 UID fetch 32268 (UID RFC822.SIZE BODY[]
<16384.10240>)
Mon 2002-10-21 11:10:57: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:10:57: [804:41] 12 OK FETCH completed
Mon 2002-10-21 11:10:57: [804:41] 13 UID fetch 32268 (UID RFC822.SIZE BODY[]
<26624.12288>)
Mon 2002-10-21 11:10:57: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:10:57: [804:41] 13 OK FETCH completed
Mon 2002-10-21 11:10:57: [804:41] 14 UID fetch 32268 (UID RFC822.SIZE BODY[]
<38912.14336>)
Mon 2002-10-21 11:10:57: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:10:57: [804:41] 14 OK FETCH completed
Mon 2002-10-21 11:10:57: [804:41] 15 UID fetch 32268 (UID RFC822.SIZE BODY[]
<53248.16384>)
Mon 2002-10-21 11:10:57: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:10:57: [804:41] 15 OK FETCH completed
Mon 2002-10-21 11:10:57: [804:41] 16 UID fetch 32268 (UID RFC822.SIZE BODY[]
<69632.18432>)
Mon 2002-10-21 11:10:57: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:10:57: [804:41] 16 OK FETCH completed
Mon 2002-10-21 11:10:57: [804:41] 17 UID fetch 32268 (UID RFC822.SIZE BODY[]
<88064.20480>)
Mon 2002-10-21 11:10:57: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:10:57: [804:41] 17 OK FETCH completed
Mon 2002-10-21 11:10:57: [804:41] 18 UID fetch 32268 (UID RFC822.SIZE BODY[]
<108544.22095>)
Mon 2002-10-21 11:10:57: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:10:57: [804:41] 18 OK FETCH completed
Mon 2002-10-21 11:11:03: [804:41] 19 uid store 32268 -Flags (\Seen)
Mon 2002-10-21 11:11:03: [804:41] * 3092 FETCH (UID 32268 FLAGS (\Recent))
Mon 2002-10-21 11:11:03: [804:41] 19 OK STORE completed
Mon 2002-10-21 11:11:05: [804:41] 20 UID fetch 32270 (UID RFC822.SIZE BODY[])
Mon 2002-10-21 11:11:05: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:11:05: [804:41] 20 OK FETCH completed
Mon 2002-10-21 11:11:09: [804:41] 21 uid store 32270 -Flags (\Seen)
Mon 2002-10-21 11:11:09: [804:41] * 3094 FETCH (UID 32270 FLAGS (\Recent))
Mon 2002-10-21 11:11:09: [804:41] 21 OK STORE completed
Mon 2002-10-21 11:11:11: [804:41] 22 UID fetch 32262 (BODYSTRUCTURE)
Mon 2002-10-21 11:11:11: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:11:11: [804:41] 22 OK FETCH completed
Mon 2002-10-21 11:11:11: [804:41] 23 UID fetch 32262 (UID RFC822.SIZE BODY[]
<0.28672>)
Mon 2002-10-21 11:11:11: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:11:11: [804:41] 23 OK FETCH completed
Mon 2002-10-21 11:11:12: [804:41] 24 UID fetch 32262 (UID RFC822.SIZE BODY[]
<28672.28672>)
Mon 2002-10-21 11:11:12: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:11:12: [804:41] 24 OK FETCH completed
Mon 2002-10-21 11:11:12: [804:41] 25 UID fetch 32262 (UID RFC822.SIZE BODY[]
<57344.30720>)
Mon 2002-10-21 11:11:12: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:11:12: [804:41] 25 OK FETCH completed
Mon 2002-10-21 11:11:12: [804:41] 26 UID fetch 32262 (UID RFC822.SIZE BODY[]
<88064.32768>)
Mon 2002-10-21 11:11:12: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:11:12: [804:41] 26 OK FETCH completed
Mon 2002-10-21 11:11:12: [804:41] 27 UID fetch 32262 (UID RFC822.SIZE BODY[]
<120832.34816>)
Mon 2002-10-21 11:11:12: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:11:12: [804:41] 27 OK FETCH completed
Mon 2002-10-21 11:11:12: [804:41] 28 UID fetch 32262 (UID RFC822.SIZE BODY[]
<155648.36864>)
Mon 2002-10-21 11:11:12: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:11:12: [804:41] 28 OK FETCH completed
Mon 2002-10-21 11:11:12: [804:41] 29 UID fetch 32262 (UID RFC822.SIZE BODY[]
<192512.38912>)
Mon 2002-10-21 11:11:12: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:11:12: [804:41] 29 OK FETCH completed
Mon 2002-10-21 11:11:12: [804:41] 30 UID fetch 32262 (UID RFC822.SIZE BODY[]
<231424.40960>)
Mon 2002-10-21 11:11:12: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:11:12: [804:41] 30 OK FETCH completed
Mon 2002-10-21 11:11:12: [804:41] 31 UID fetch 32262 (UID RFC822.SIZE BODY[]
<272384.43008>)
Mon 2002-10-21 11:11:12: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:11:12: [804:41] 31 OK FETCH completed
Mon 2002-10-21 11:11:13: [804:41] 32 UID fetch 32262 (UID RFC822.SIZE BODY[]
<315392.45056>)
Mon 2002-10-21 11:11:13: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:11:13: [804:41] 32 OK FETCH completed
Mon 2002-10-21 11:11:13: [804:41] 33 UID fetch 32262 (UID RFC822.SIZE BODY[]
<360448.47104>)
Mon 2002-10-21 11:11:13: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:11:13: [804:41] 33 OK FETCH completed
Mon 2002-10-21 11:11:13: [804:41] 34 UID fetch 32262 (UID RFC822.SIZE BODY[]
<407552.49152>)
Mon 2002-10-21 11:11:13: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:11:13: [804:41] 34 OK FETCH completed
Mon 2002-10-21 11:11:13: [804:41] 35 UID fetch 32262 (UID RFC822.SIZE BODY[]
<456704.51200>)
Mon 2002-10-21 11:11:13: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:11:13: [804:41] 35 OK FETCH completed
Mon 2002-10-21 11:11:13: [804:41] 36 UID fetch 32262 (UID RFC822.SIZE BODY[]
<507904.7590>)
Mon 2002-10-21 11:11:13: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:11:13: [804:41] 36 OK FETCH completed
Mon 2002-10-21 11:11:14: [804:41] 37 uid store 32262 -Flags (\Seen)
Mon 2002-10-21 11:11:14: [804:41] * 3086 FETCH (UID 32262 FLAGS (\Recent))
Mon 2002-10-21 11:11:14: [804:41] 37 OK STORE completed
Mon 2002-10-21 11:11:17: [804:41] 38 UID fetch 32258 (UID RFC822.SIZE BODY[])
Mon 2002-10-21 11:11:17: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:11:17: [804:41] 38 OK FETCH completed
Mon 2002-10-21 11:11:18: [804:41] 39 uid store 32258 -Flags (\Seen)
Mon 2002-10-21 11:11:18: [804:41] * 3082 FETCH (UID 32258 FLAGS (\Recent))
Mon 2002-10-21 11:11:18: [804:41] 39 OK STORE completed
Mon 2002-10-21 11:11:20: [804:41] 40 UID fetch 32255 (UID RFC822.SIZE BODY[])
Mon 2002-10-21 11:11:20: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:11:20: [804:41] 40 OK FETCH completed
Mon 2002-10-21 11:11:24: [804:41] 41 uid store 32255 -Flags (\Seen)
Mon 2002-10-21 11:11:24: [804:41] * 3079 FETCH (UID 32255 FLAGS (\Recent))
Mon 2002-10-21 11:11:24: [804:41] 41 OK STORE completed
Mon 2002-10-21 11:11:26: [804:41] 42 UID fetch 32256 (UID RFC822.SIZE BODY[])
Mon 2002-10-21 11:11:26: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:11:26: [804:41] 42 OK FETCH completed
Mon 2002-10-21 11:11:27: [804:41] 43 uid store 32256 -Flags (\Seen)
Mon 2002-10-21 11:11:27: [804:41] * 3080 FETCH (UID 32256 FLAGS (\Recent))
Mon 2002-10-21 11:11:27: [804:41] 43 OK STORE completed
Mon 2002-10-21 11:12:22: [804:41] 44 UID fetch 32251 (UID RFC822.SIZE BODY[])
Mon 2002-10-21 11:12:22: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:12:22: [804:41] 44 OK FETCH completed
Mon 2002-10-21 11:20:50: [804:41] 45 noop
Mon 2002-10-21 11:20:50: [804:41] * 3095 EXISTS
Mon 2002-10-21 11:20:50: [804:41] * 2832 RECENT
Mon 2002-10-21 11:20:50: [804:41] 45 OK NOOP completed
Mon 2002-10-21 11:20:50: [804:41] 46 UID fetch 32271:* (FLAGS)
Mon 2002-10-21 11:20:50: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:20:50: [804:41] 46 OK FETCH completed
Mon 2002-10-21 11:20:51: [804:41] 47 UID fetch 32271 (UID RFC822.SIZE FLAGS 
BODY.PEEK[HEADER.FIELDS (From To Cc Subject Date Priority X-Priority Message-ID 
References Newsgroups Return-Receipt-To Disposition-Notification-To)]
Mon 2002-10-21 11:20:51: [804:41] Sending FETCH response (not logged)...
Mon 2002-10-21 11:20:51: [804:41] 47 OK FETCH completed
Mon 2002-10-21 11:23:39: [804:41] 48 uid copy 
29122,29460:29461,29499:29506,29508:29639,29641:29711,29713:29775,29777:30146,30
148:30685,30687:30966,30968:31671,31673:31788,31790:31927,31929:31958,31960:3197
1,31973:32028,32031
Mon 2002-10-21 11:24:02: [804:41] 48 OK COPY completed
Mon 2002-10-21 11:24:02: [804:41] 49 uid store 
29122,29460:29461,29499:29506,29508:29639,29641:29711,29713:29775,29777:30146,30
148:30685,30687:30966,30968:31671,31673:31788,31790:31927,31929:31958,31960:3197
1,31973:32028,3203
Mon 2002-10-21 11:24:02: [804:41] * 227 FETCH (UID 29122 FLAGS (\Seen \Deleted))
Mon 2002-10-21 11:24:02: [804:41] * 284 FETCH (UID 29460 FLAGS (\Deleted 
\Recent))
Mon 2002-10-21 11:24:02: [804:41] * 285 FETCH (UID 29461 FLAGS (\Deleted 
\Recent))
Mon 2002-10-21 11:24:02: [804:41] * 323 FETCH (UID 29499 FLAGS (\Deleted 
\Recent))
Mon 2002-10-21 11:24:02: [804:41] * 324 FETCH (UID 29500 FLAGS (\Deleted 
\Recent))
Mon 2002-10-21 11:24:02: [804:41] * 325 FETCH (UID 29501 FLAGS (\Deleted 
\Recent))
Mon 2002-10-21 11:24:02: [804:41] * 326 FETCH (UID 29502 FLAGS (\Deleted 
\Recent))
...
<snip>
...
Mon 2002-10-21 11:24:03: [804:41] * 2944 FETCH (UID 32120 FLAGS (\Deleted 
\Recent))
Mon 2002-10-21 11:24:03: [804:41] * 2945 FETCH (UID 32121 FLAGS (\Deleted 
\Recent))
Mon 2002-10-21 11:24:03: [804:41] * 2946 FETCH (UID 32122 FLAGS (\Deleted 
\Recent))
Mon 2002-10-21 11:24:03: [804:41] * 2947 FETCH (UID 32123 FLAGS (\Deleted 
\Recent))
Mon 2002-10-21 11:24:03: [804:41] * 2948 FETCH (UID 32124 FLAGS (\Deleted 
\Recent))
Mon 2002-10-21 11:24:03: [804:41] * 2949 FETCH (UID 32125 FLAGS (\Deleted 
\Recent))
Mon 2002-10-21 11:24:03: [804:41] * 2951 FETCH (UID 32127 FLAGS (\Deleted 
\Recent))
Mon 2002-10-21 11:24:03: ---------- End partial transcript.

Comment 2

15 years ago
Mail *server* crashing is not a Mozilla bug

-> INVALID

Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

15 years ago
I agree with you that the server crash is not a Mozilla bug; but if the crash is 
caused by syntax errors by Mozilla's IMAP implementation then it should _at 
least_ be investigated to be sure.

Especially since other clients appear not to cause this error. (Just because one 
server chokes on it doesn't mean all other servers will handle this thing 
gracefully!).
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

15 years ago
They do, thats a mailserver thing
-->Resolving Invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

15 years ago
*Sigh* 
I will take your word for it then (that other clients do cause the same issues). 

The MDaemon folks have been notified.
I guess we're stuck with Netscape 4 until MDaemon does something about this.

Updated

15 years ago
QA Contact: huang → gchan
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.