Character Coding is wrong

RESOLVED WORKSFORME

Status

()

Core
Internationalization
RESOLVED WORKSFORME
16 years ago
2 years ago

People

(Reporter: Jens Nixdorf, Assigned: Roy Yokoyama)

Tracking

({intl})

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; de-AT; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; de-AT; rv:1.2a) Gecko/20020910

Every time the browser starts in Character Coding=Unicode (UTF8). In preferences
the Default Character Coding is set to Western (ISO 8859-1). It "works" on all
URL's. The Auto-Detect-Feature is "OFF", but this makes no difference.

Reproducible: Always

Steps to Reproduce:
1.Start Mozilla
2.Enter an URL
3.Look at it ;)




My System is _german_ Win ME.

Comment 1

16 years ago
Not directly to your Bug, but Mozilla/5.0 (Windows; U; Win 9x 4.90; de-AT;
rv:1.2a) Gecko/20020910; there is no Language-Pack for 1.2a, have you installed
an old one for Mozilla?
(Reporter)

Comment 2

16 years ago
No, it was installed over an older version. In preferences/Appearance/Languages
the de_AT Language-Pack does _not_ appear.
->Internationalization
Assignee: asa → yokoyama
Component: Browser-General → Internationalization
QA Contact: asa → ruixu

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → ylong

Comment 4

16 years ago
Jens Nixdorf:
Could you please try to mark charset as iso-8859-1 then clear th Cache (Edit |
Preferences | Advanced | Cache) to see if there is any difference?

Could you please also try to launch brower by profile manager and create a new
profile?
(Reporter)

Comment 5

16 years ago
by testing your suggestions i could see a little bit more: the wrong coding appears _only_ if i start the browser from the mail-window. It makes no difference, if it is startet by clicking an URL in a mail or by clicking the icon in the little quickstart-bar in the status-bar or by hitting ctrl+1. Also it makes no difference, if the cache is empty or not or if i create a new profile to start from.  Short: Started from Mail+News the Char-Coding is in Unicode, started directly as browser it is iso-8859-1.  rgds, Jens  

Comment 6

16 years ago
You mean you only see it when start from Mail & News?  what's your default
charset in your Edit | Peferences | Mail & Newsgroup | Message Display |
Character Coding?

But if you start with a new profile, the default charset is always set to
iso-8859-1, unless the mail message itself has unicode encoding.

cc Naoki and Marina regarding for mail.
(Reporter)

Comment 7

16 years ago
Yes, i see it only when i start from Mail & News. Default Charset for Message Display is also set to iso-8859-1.  rgds, Jens  
(Reporter)

Comment 8

16 years ago
Additional Info: The wrong charset is only active, if i start the browser from
Mail & News _and_ it will be the first browser-window. If a browser-window is
open from another session and maybe i click an URL in a mail and the old
browser-window opens this URL, then the last active charset is used. So if i
have choosen the right charset in the session before and click on a new URL in a
mail, the browser-window will be updateted with the right charset.
This has nothing to do with closing the complete mozilla, if i close only the
browser and Mail & News is still active, every new browser-window started from
mail  has the wrong charset.

rgds, Jens

Comment 9

16 years ago
I have the same kind of bug. When I click an URL in mail&news, the browsers
character coding changes to Unicode (UTF-8). I have to change the coding back to
Western (ISO-8859-1) (View -> Character coding -> Western (ISO-8859-1))
_every_time_ I click some URL in mail&news, otherwise the scandinavian
characters (at least ä and ö) are displayed as question marks (?).

My system:
English Win2000 Pro, SP3
Mozilla 1.2b (build: 2002101612)
(this same bug exsisted already in Mozilla 1.1. I installed this 1.2b by NOT
uninstalling the previous version)

In preferences:
Navigator -> Languages: First language is English [en], second Finnish [fi].
Default character coding is Western (ISO-8859-1).
Mail & Newsgroups -> Message display: Character coding is Western (ISO-8859-1).
[YES] Apply default to all messages (ignore character coding specified by MIME
header).
Mail & Newsgroups -> Composition: [NO] For messages that contain 8-bit
characters, use 'quoted printable' MIME encoding. Leave unchecked to send the
message as is. Character coding is Western (ISO-8859-15).

Comment 10

16 years ago
Now I have tested this in Mozilla 1.1 (Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.1) Gecko/20020826) (because of some other annoying bugs in 1.2b). I
have noticed that the character coding changes to UTF-8 if there is no
Content-Type defined on the site.
(Reporter)

Comment 11

16 years ago
Now i have running at home Mozilla 1.3a (Mozilla/5.0 (Windows; U; Windows NT
5.1; de-AT; rv:1.3a) Gecko/20021212) and it has again the same behaviour. But
maybe it has something to do with the language pack. All my mozilla's at all my
computers are sometimes overwritten by newer ones. And all of them has sometimes
got the austrian/german-language-pack. For the mozilla 1.3x there is no german
language-pack yet, but it says "de-AT" if i click at the "Help/about"-menu. 

Comment 12

16 years ago
It still works for me with current steps in this bug, but I'm going to confirm
it to get more input from other people.
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: amyy → i18n
This failure mode should be impossible now.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.