Drag and drop from an empty zone of the bookmarks toolbar gives weird results

VERIFIED DUPLICATE of bug 170793

Status

()

Firefox
Bookmarks & History
VERIFIED DUPLICATE of bug 170793
16 years ago
15 years ago

People

(Reporter: Sébastien Delahaye, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021020
Phoenix/0.3 on w2k.

Drag and drop empty spaces from the bookmarks toolbar can give weird results.

Left-click on an empty zone of the bookmark, and keep the left button pressed.
Drag and drop to a tab. It will display twice an alert Message Box saying "NC is
not a registered protocol.".
Make another drag and drop to an empty zone of the tabbar: it'll create a new
(empty) tab and display twice the same message box.

Now, make another drag and drop (again from an empty zone of the bookmarks
toolbar) to the page you are viewing. The same message box is displayed, but
only once.

Finally, you can make another drag and drop to the Location bar. It will add
"NC:PersonalToolbarFolder" to the location bar.

On a side note, if you click on an empty zone of the bookmarks toolbar, you have
a menu with the following entries:

New Folder...
----------
Cut
Copy
Paste
----------
Delete
----------
Properties

I'm not sure, but I don't think the Cut/Copy/paste stuff should be there. I can
find a different bug for this if necessary.

Comment 1

16 years ago
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 170793 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

15 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.