Closed Bug 1757756 Opened 11 months ago Closed 11 months ago

Permafailing wasi js/src/util/GetPidProvider.h:14:11: note: macro 'getpid' defined here when Gecko 99 merges to Beta on 2022-03-08

Categories

(Core :: JavaScript Engine, defect, P1)

defect

Tracking

()

VERIFIED FIXED
100 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox97 --- unaffected
firefox98 --- unaffected
firefox99 --- fixed
firefox100 --- verified

People

(Reporter: nataliaCs, Assigned: jandem)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

[Tracking Requested - why for this release]:

[task 2022-03-02T12:20:08.036Z] In file included from /builds/worker/workspace/obj-spider/dist/system_wrappers/unistd.h:3:
[task 2022-03-02T12:20:08.036Z] /builds/worker/fetches/sysroot-wasm32-wasi/include/unistd.h:156:14: error: too many arguments provided to function-like macro invocation
[task 2022-03-02T12:20:08.036Z] pid_t getpid(void);
[task 2022-03-02T12:20:08.037Z]              ^
[task 2022-03-02T12:20:08.037Z] /builds/worker/checkouts/gecko/js/src/util/GetPidProvider.h:14:11: note: macro 'getpid' defined here
[task 2022-03-02T12:20:08.038Z] #  define getpid() 1
[task 2022-03-02T12:20:08.038Z]           ^
[task 2022-03-02T12:20:08.038Z] 1 error generated.
[task 2022-03-02T12:20:08.038Z] gmake[4]: *** [/builds/worker/checkouts/gecko/config/rules.mk:659: Unified_cpp_js_src12.o] Error 1
[task 2022-03-02T12:20:08.038Z] gmake[4]: Leaving directory '/builds/worker/workspace/obj-spider/js/src'
[task 2022-03-02T12:20:08.038Z] gmake[4]: *** Waiting for unfinished jobs....

Could be a fallout of Bug 1757273?
Ryan, do you have a few minutes to check?

Flags: needinfo?(rhunt)

It looks wasi related, it seems unlikely to be a regression from bug 1757273. Jan, do you have any idea what this might be from?

Flags: needinfo?(rhunt) → needinfo?(jdemooij)

zlib includes unistd.h and the definition of getpid there conflicted with the macro
in GetPidProvider.h, breaking the WASI build on beta.

Assignee: nobody → jdemooij
Status: NEW → ASSIGNED
Flags: needinfo?(jdemooij)

The patch seems to be working as of today's central as beta simulation.

Blocks: sm-meta
Severity: -- → S4
Priority: -- → P3
Priority: P3 → P1
Pushed by jdemooij@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/399e883cdcd2
Use emulated getpid for WASI to fix the beta-simulation build. r=glandium
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 100 Branch

Fix verified in today's beta-sim.

Status: RESOLVED → VERIFIED

Please submit an uplift request.

Flags: needinfo?(jdemooij)

Comment on attachment 9266257 [details]
Bug 1757756 - Use emulated getpid for WASI to fix the beta-simulation build. r?glandium!

Beta/Release Uplift Approval Request

  • User impact if declined: Broken WASI build on beta.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Doesn't affect Firefox.
  • String changes made/needed: N/A
Flags: needinfo?(jdemooij)
Attachment #9266257 - Flags: approval-mozilla-beta?

Comment on attachment 9266257 [details]
Bug 1757756 - Use emulated getpid for WASI to fix the beta-simulation build. r?glandium!

Approved for 99.0b3. Thanks.

Attachment #9266257 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.