Closed Bug 1758094 Opened 7 months ago Closed 5 months ago

Crash in [@ libxul.so@0x3672dc3 | libwayland-client.so.0@0xc68a]

Categories

(Core :: Graphics, defect)

Firefox 99
x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1760001
Tracking Status
firefox99 --- affected

People

(Reporter: brian, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Crash Data

Firefox 99 has a high likelihood of crashing when I move any window from my desktop monitor (4K display at 100% DPI scale) to my laptop's built-in display (4K display at 200% DPI scale). It seems to have an issue with switching that window over to 200% scale.

Running Ubuntu 22.04 pre-release build with Wayland and Gnome 42 beta.

Maybe Fission related. (DOMFissionEnabled=1)

Crash report: https://crash-stats.mozilla.org/report/index/2bbd86de-0e3c-4d15-84c4-a4cd70220304

MOZ_CRASH Reason: ```wl_surface@49: error 2: Buffer size (1481x992) must be an integer multiple of the buffer_scale (2)


Top 10 frames of crashing thread:

0 libxul.so libxul.so@0x0000000003672dc3
1 libwayland-client.so.0 libwayland-client.so.0@0x000000000000c68a
2 libwayland-client.so.0 libwayland-client.so.0@0x0000000000006b5a
3 libffi.so.7 libffi.so.7@0x00000000000083d4
4 libffi.so.7 libffi.so.7@0x000000000000685b
5 libwayland-client.so.0 libwayland-client.so.0@0x0000000000006afd
6 libgdk-3.so.0 libgdk-3.so.0@0x000000000007a90f
7 libwayland-client.so.0 libwayland-client.so.0@0x000000000000aa96
8 libwayland-client.so.0 libwayland-client.so.0@0x0000000000010aff
9 libffi.so.7 libffi.so.7@0x000000000000915f

Looks the same as another bug.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1760001
You need to log in before you can comment on or make changes to this bug.