Closed Bug 1758739 Opened 5 months ago Closed 1 month ago

Calendar doesn't respect "Date and Time Formatting" date format

Categories

(Calendar :: Calendar Frontend, defect)

Unspecified
All
defect

Tracking

(thunderbird_esr102+ fixed, thunderbird103 fixed)

RESOLVED FIXED
104 Branch
Tracking Status
thunderbird_esr102 + fixed
thunderbird103 --- fixed

People

(Reporter: Paenglab, Assigned: darktrojan)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

I use a en-US Daily. In the settings I can set underDate and Time Formatting if I want the Application locale or the Regional settings locale. TB follows on all elements this setting. Only Calendar stays on the en-US date with AM/PM.

TB 91 seems to work correctly. Alice, can you find a regression range here? Just use TB on a non-en-US system and check how the dates are displayed. In the calendar I see "AM/PM" being used which is not the case elsewhere in the UI.

Flags: needinfo?(alice0775)
Flags: needinfo?(geoff)

Overall the fix for bug 1752130 appears to be wrong and should just be backed out. Dates/Times are formatted according to the Application Locale or Regional Settings Locale depending on which setting is chosen. Strings in the UI are taken from the application Locale. So if the user uses an English version of TB and regional settings for French, then unavoidably there will be "Day" together with "février" ("February"). Apparently the wording in the date picker/matrix follows the application locale showing "February".

The idea behind the design was that people can use an en-US version of the application and at the same time enjoy their local date/time formatting, for example according to en-AU or en-GB rules.

proactively assigning

Assignee: nobody → geoff
Severity: -- → S3
OS: Unspecified → All

https://github.com/Betterbird/thunderbird-patches/blob/main/102/bugs/backout-bug-1752130-for-causing-bug-1758739-date-format.patch
Not a straight backout since bug 1749011 got in the way on calDateTimeFormatter.jsm. BTW, bug 1749011 should be closed, otherwise it will wait for bug 1749459 (P3/S3) for a long time.

Flags: needinfo?(geoff)
Duplicate of this bug: 1777873

Okay, yeah, this is dumb but it doesn't need several people repeating the same information.

Essentially a backout of https://hg.mozilla.org/comm-central/rev/28f648f37dd1 which I never should've wasted my time on in the first place.

Status: NEW → ASSIGNED

Thanks, Geoff! r=BenB, FWIW

Target Milestone: --- → 104 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/2ee5a46c3f61
Back out changes of bug 1752130. r=#thunderbird-reviewers,BenB

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Duplicate of this bug: 1778588

Comment on attachment 9284415 [details]
Bug 1758739 - Back out changes of bug 1752130. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #): bug 1752130
User impact if declined: Users get strings in the application language whether they want them or not
Testing completed (on c-c, etc.): 6 days
Risk to taking this patch (and alternatives if risky): This is just the old behaviour, so no.

Attachment #9284415 - Flags: approval-comm-beta?
Duplicate of this bug: 1779826

Comment on attachment 9284415 [details]
Bug 1758739 - Back out changes of bug 1752130. r=#thunderbird-reviewers

[Triage Comment]
Approved for beta

Attachment #9284415 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9284415 [details]
Bug 1758739 - Back out changes of bug 1752130. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #): bug 1752130
User impact if declined: Users get strings in the application language whether they want them or not
Testing completed (on c-c, etc.): In 103 b6
Risk to taking this patch (and alternatives if risky): This is just the old behaviour, so no.

Attachment #9284415 - Flags: approval-comm-esr102?

Comment on attachment 9284415 [details]
Bug 1758739 - Back out changes of bug 1752130. r=#thunderbird-reviewers

[Triage Comment]
Approved for esr102

Attachment #9284415 - Flags: approval-comm-esr102? → approval-comm-esr102+
You need to log in before you can comment on or make changes to this bug.