Closed Bug 1758779 Opened 2 years ago Closed 2 years ago

browser.download.panel.shown gets re-enabled on every download

Categories

(Firefox :: Downloads Panel, defect)

Firefox 98
defect

Tracking

()

RESOLVED DUPLICATE of bug 1749998

People

(Reporter: hguijtra, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:98.0) Gecko/20100101 Firefox/98.0

Steps to reproduce:

Right-click an image, select "save image as". The download panel opens (this is undesired; I'll open it if I need it, I don't need it jumping in my face every single time).
To combat the problem, I set browser.download.panel.shown to false.
Right-click an image, select "save image as". The setting for browser.download.panel.shown gets automatically re-enabled, and the download panel opens again. Why even bother having a setting if you are just going to overwrite it every time?

Actual results:

The download panel keeps popping up when it is not needed.

Expected results:

It should respect my setting for browser.download.panel.shown when I set it to false.

The Bugbug bot thinks this bug should belong to the 'Firefox::Downloads Panel' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Downloads Panel

Isn't the correct setting browser.download.alwaysOpenPanel?

(In reply to Robert Longson [:longsonr] from comment #2)

Isn't the correct setting browser.download.alwaysOpenPanel?

This is correct. I'll dupe this over to the bug where we're considering adding UI somewhere for this preference.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE

(In reply to hguijtra from comment #0)

The setting for browser.download.panel.shown gets automatically re-enabled, and the download panel opens again. Why even bother having a setting if you are just going to overwrite it every time?

So to offer some more context, the thing you changed (rather than the correct setting in comment #2) isn't really a setting, it is a classic example of legacy Firefox code using the prefs database as a key/value store (there are many others; it's not specific to downloads code). This "pref" has existed for close to 10 years, and only stores whether or not the panel has ever been opened. It does not control whether it will open for new downloads in general.

CAN'T confirm this Bug with Fedora Linux 98.0-2

browser.download.alwaysOpenPanel = false

works as expected here.

You need to log in before you can comment on or make changes to this bug.