Undo delete message broken by lack of trash index

VERIFIED DUPLICATE of bug 198909

Status

VERIFIED DUPLICATE of bug 198909
16 years ago
10 years ago

People

(Reporter: jasonab, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
If you delete a message in Mozilla 1.2b before accessing the trash folder, the
message cannot be undeleted. Once the trash has been opened, and the index
rebuilt, messages can be undeleted again.

Updated

16 years ago
QA Contact: gayatri → stephend

Comment 1

16 years ago
I see the same behavior with BuildID 2002103002 (trunk) on RedHat Linux 8.0 -
"Undo delete" does not work until I visit the "Trash" folder for the first time.
Not sure if this is a DB problem, or a FE problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
(Assignee)

Comment 2

16 years ago
it's an undo problem. Undo shouldn't rely on the headers being in the trash db,
because, obviously, they may not be in the trash db.
(Reporter)

Comment 3

16 years ago
I've noticed that in 1.2b, Mail/News tends to reindex folders on a regular basis
(much more than older versions did). I'm not sure if indexes are being lost, or
if this is intentional.
(Assignee)

Comment 4

16 years ago
if indexes are being invalidated, it's not by design (though we may be checking
for invalid db's in more cases). Is it all indexes, or the trash in particular?
(Reporter)

Comment 5

16 years ago
It's all of them at some point in time, although the trash is the most noticable
one for me.
(Assignee)

Comment 6

16 years ago
dup of 198909 - that's where the proposed fix is going.

*** This bug has been marked as a duplicate of 198909 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
verified.
Status: RESOLVED → VERIFIED
QA Contact: stephend → esther
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.