messed target if two frames in different framesets (windows) have the same name (like "main" for example)

RESOLVED DUPLICATE of bug 103638

Status

()

Core
Layout: HTML Frames
P2
major
RESOLVED DUPLICATE of bug 103638
15 years ago
14 years ago

People

(Reporter: Alexandru Savulov, Assigned: John Keiser (jkeiser))

Tracking

({testcase})

Trunk
Future
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

1.39 KB, application/octet-stream
Details
(Reporter)

Description

15 years ago
excerpt from a disscution with jkeiser:

savulov (8:40:08 PM): who is in charge of loading in frames, framesets?
John Keiser (8:48:43 PM): Me, Johnny and Kin know the most about it
savulov (8:49:00 PM): then you should get this bug :-)
John Keiser (8:49:25 PM): heh :-)
savulov (8:49:27 PM): you can try it immediatelly and report it your self. is funny
John Keiser (8:49:27 PM): What's the problem?
John Keiser (8:49:33 PM): Go ahead and give it to me
John Keiser (8:49:37 PM): What is it?
savulov (8:49:43 PM): ok, do what i say
savulov (8:49:50 PM): open a mozilla window
savulov (8:50:00 PM): go to http://www.iarchitect.com/mshame.htm
savulov (8:50:10 PM): open a new window
savulov (8:50:46 PM): (place it so you can see at least the upper part of he
first ones main frame)
savulov (8:51:10 PM): navigate to http://www.lametaltv.com/ (in the second)
savulov (8:51:26 PM): now click on the links there (next show...)
savulov (8:51:38 PM): see what happens in the first window
savulov (8:52:39 PM): it might be DOM too
savulov (8:52:51 PM): both main frames have the name "main"
John Keiser (8:53:06 PM): oh, that might be related to one of mine
John Keiser (8:53:32 PM): Yeah, curse it
John Keiser (8:53:37 PM): I know which one that is
savulov (8:53:56 PM): you do?
John Keiser (8:54:41 PM): hmmmm
John Keiser (8:54:43 PM): No, not sure now
John Keiser (8:54:47 PM): But it's probably related
John Keiser (8:55:03 PM): If you load the windows in the opposite order it
probably won't happen
savulov (8:55:20 PM): if you don't anvigate to the first URL, it will open a new
window
savulov (8:55:30 PM): when you click on the menu
savulov (8:56:34 PM): there's also a missing <script> tag in the menu.html
savulov (8:56:52 PM): but that is not the problem i think
savulov (8:57:04 PM): is the fact that both windows are called "main"
savulov (8:57:47 PM): funky, isn't?
John Keiser (8:58:17 PM): yeah, I've had a problem like that before, but it was
with window.open
John Keiser (8:58:17 PM): cc me
John Keiser (8:58:27 PM): It was searching for the "main" window wrong
savulov (8:58:43 PM): cc you for what?
savulov (8:59:02 PM): i thought you want to open the bug :-)
savulov (8:59:11 PM): kidding
savulov (8:59:16 PM): shall i?
savulov (9:00:19 PM): who shall get it?
savulov (9:00:43 PM): dude! you copy? :-)
savulov (9:04:04 PM): duuuuude!

bug filled to jkeiser
(Reporter)

Comment 1

15 years ago
now seriously

steps to repro:

1. open a mozilla window
2. go to http://www.iarchitect.com/mshame.htm
3. open a new window
4. (place it so you can see at least the upper part of the first ones main frame)
5. navigate to http://www.lametaltv.com/ (in the second)
6. now click on the links there (next show...)

Result:
the documents are loaded in the main frame of the first window

Expected.
the documents are loaded in the main frame of the second window (of course)

Hint:
both main frames have name="main". 

Note:
If only http://www.lametaltv.com/ is opened in a window, the first click on a
link will open a new one. the frameset loads wrong be cause the main frame will
be not loaded.

Updated

15 years ago
Priority: -- → P2

Updated

15 years ago
Target Milestone: --- → Future

Comment 2

15 years ago
Created attachment 109803 [details]
Testcase

Updated

15 years ago
Keywords: testcase

Comment 3

15 years ago
Duplicate of bug 103638?

Comment 4

14 years ago
Impossible to reproduce this bug as the first URL is no longer valid.



*** This bug has been marked as a duplicate of 103638 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.