XML document without stylesheet not displayed

VERIFIED FIXED in M12

Status

()

Core
XML
P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: dbaron, Assigned: rickg)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

19 years ago
DESCRIPTION: XML documents without a stylesheet no longer show up.  They should,
in particular when they use namespaces (HTML, MathML, XUL) about which Mozilla
has knowledge.

STEPS TO REPRODUCE:
 * load first of attach test cases

ACTUAL RESULTS:
 * some leftover painting

EXPECTED RESULTS:
 * "This is an XML-ish document."

DOES NOT WORK CORRECTLY ON:
 * Linux, apprunner, 1999-10-29-10-M11

WORKS CORRECTLY ON:
 * older builds
(Reporter)

Comment 1

19 years ago
Created attachment 2493 [details]
simple XML document
(Reporter)

Comment 2

19 years ago
Created attachment 2494 [details]
similar document that works (added stylesheet and spread DOCTYPE to multiple lines)
(Reporter)

Comment 3

19 years ago
Created attachment 2495 [details]
similar document that works (added stylesheet and spread DOCTYPE to multiple lines)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M11

Comment 4

19 years ago
Accepting bug and setting milestone to M11 for now...

Updated

19 years ago
Assignee: nisheeth → rickg
Status: ASSIGNED → NEW

Comment 5

19 years ago
Re-assigning to Rick as per our conversation.  The HTML DTD is being selected
over the XML DTD to handle this document because the document contains "html
doctype public" inside it.  BufferContainsHTML() probably needs to be changed to
check for the XML Decl and return FALSE if it is found.
(Assignee)

Comment 6

19 years ago
This is now fixed in my tree, awaiting m12 opening.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 7

19 years ago
Why isn't the MIME type text/xml enough?

Updated

19 years ago
Target Milestone: M11 → M12

Comment 8

19 years ago
if this doesn't arrive then lets move target milestone to m12
(Assignee)

Comment 9

19 years ago
Mime types can be misleading. If you tell me you have an XML file, I still need
to determine whether I have a DTD for that XML application (or not). What's
more I've seen HTML files given as text/plain.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

19 years ago
Fixed by autodetection code in CNavDTD. The code was too aggressive about taking
ownership of a document if it spotted HTML.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 11

19 years ago
Using 11/16 build on Linux, verified fixed. XML page displays.
You need to log in before you can comment on or make changes to this bug.