x-remote should open a new window if none exists

RESOLVED WONTFIX

Status

()

Core
X-remote
RESOLVED WONTFIX
15 years ago
14 years ago

People

(Reporter: Sameer D. Sahasrabuddhe, Assigned: blizzard)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021021
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021021

$ mozilla-xremote-client "openURL()"
$ mozilla -remote "openURL()"

Running either of these when no instance of mozilla is open produces no result.
It should instead open a new window ... most useful when one wants to create a
launcher on the desktop.

Reproducible: Always

Steps to Reproduce:
(Assignee)

Comment 1

15 years ago
This is entirely by design.  I'm not going to change the behaviour of this
because it's been like this for years.  Mozilla will return a different exit
code if it didn't find a window, for what it's worth.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
*** Bug 166096 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
*** Bug 221567 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
Don't take this the wrong way
but that is a rather POOR method of handling this form of opening.
this would be like saying under windows if a user clicks on a url
in another program then if mozilla isn't running then tough luck!

The only way to open a URL under linux into an already running mozilla instance
is via this method. It should not be up to the average user (who you are trying
to help) to figure out how to make a script to determine if mozilla is running
or not and open it a different way if it isn't.
I'm sure that this would take next to no time to implement.
Not implementing it makes it impossible to use mozilla under linux to open up
html files from disk or from other applications when there is already an
instance running.
Without the script the opening method is one or the other

Please reconsider this OR
include some code at the start of the mozilla script to determine if mozilla is
already running!
You need to log in before you can comment on or make changes to this bug.