Open Bug 1759587 Opened 7 months ago Updated 6 months ago

mozregression-gui is broken with Qt 5.15.3

Categories

(Testing :: mozregression, defect)

Default
Desktop
Linux
defect

Tracking

(Not tracked)

UNCONFIRMED

People

(Reporter: tustamido, Unassigned, NeedInfo)

Details

I use Manjaro KDE and today Pacman notified about many available updates. After updating, most of mozregression-gui is broken because of this error:

Cannot mix incompatible Qt library (5.15.3) with this library (5.15.2)

Some things that cause mozregression-gui to instantly crash:

  • File → Preferences
  • Help → About
  • in "Profile selection", when I click "browse" to select the folder of the profile I want to use
  • also in "Profile selection", when I click "Add from file" to select a json file with custom preferences

mozregression-gui 4.0.18

I'm new to Linux and don't know what I'm doing, but this seems to have fixed the issue for me:

  1. Moved/removed all libQt5* files away from mozregression-gui folder.
  2. Renamed/moved/removed mozregression-gui/PySide2/plugins/xcbglintegrations folder.

I guess these actions are forcing mozregression-gui to use the updated libs from /usr/lib/libQt5* and /usr/lib/qt6/plugins/xcbglintegrations/.

The severity field is not set for this bug.
:zeid, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(zeid)
You need to log in before you can comment on or make changes to this bug.