Closed Bug 1759739 Opened 7 months ago Closed 6 months ago

IPV6 URL with percent sign % causes search instead of web request (WSD printers)

Categories

(Firefox :: Address Bar, defect)

Firefox 98
defect

Tracking

()

RESOLVED DUPLICATE of bug 700999

People

(Reporter: danweiss, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:98.0) Gecko/20100101 Firefox/98.0

Steps to reproduce:

This issue concerns Firefox and WSD Printers.

In Windows 10, a WSD printer will have with a URL like this: http://[fe80::822b:f9ff:fe6a:d7de%10]:80/WebServices/Device

According to https://superuser.com/questions/99746/why-is-there-a-percent-sign-in-the-ipv6-address, this is caused by Windows adding a percent sign (%) and a number to identify which network the link-local address corresponds to.

But Firefox doesn't accept this kind of URL with a percent sign (%), and instead opens a web search.

If I remove the "%10" from the URL, Firefox visits the page fine.

It seems that the only web browser that accepts this kind of URL is Microsoft Internet Explorer.

Actual results:

Firefox gets confused by the percent sign % in the URL and opens a web search instead of accessing the printer's web interface.

Expected results:

Firefox should ignore or discard the percent sign % and local network identifier number if it appears after a link-local IPV6 address.

The Bugbug bot thinks this bug should belong to the 'Firefox::Address Bar' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Address Bar
Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 700999

I would really like this fixed, I need it a couple times a week. I am forced to use an old copy of ie and prevent it's upgrade or (run an old browser in a vm) as it is the only browser that works.

Addition Info: In my case there are 500 to 1000 devices in the building and they sometimes decide to fallback to a static out-of-box ipv4 address and causing conflicts. making it impossible to get to device webpage and reset the IP. The link local ipv6 gets me there without climbing the ladder.

You need to log in before you can comment on or make changes to this bug.