If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.
Bug 175975 (arimr.gov.pl)

arimr.gov.pl - I do not like ARIMR web page [document.all, document.layers]

VERIFIED FIXED in Future

Status

Tech Evangelism Graveyard
Polish
P1
normal
VERIFIED FIXED
15 years ago
3 years ago

People

(Reporter: Peter Bartecki, Assigned: Jacek Piskozub)

Tracking

unspecified
Future

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.2b) Gecko/20021016

First of all way tooooo many gifs.

Second if you go through the wall of never ending gifs list (you may find 
English - http://www.arimr.gov.pl/witamy_e.html 
or Polish - http://www.arimr.gov.pl/witamy.html start point handy) there's no
reward at the end. 

Site uses document.all and document.layers to build menu navigation - for exampe
here: http://www.arimr.gov.pl/sapard.html

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.arimr.gov.pl/sapard.html
2.Click on lefthand menu.


Actual Results:  
Nothing happens

Expected Results:  
New page loads.

Looks like it's time to haunt on the Government sites...
(Assignee)

Comment 1

15 years ago
Confirming and accepting.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P1
Summary: I do not like ARIMR web page [document.all, document.layers] → www.arimr.gov.pl - I do not like ARIMR web page [document.all, document.layers]
Target Milestone: --- → Oct
(Assignee)

Comment 2

15 years ago
From the page source: 
Author: Mateusz Mazur
Reply-to: vincent@waw.pdi.net

The problem with the page is strange. It defines 
ie4 = (document.all)? true:false
but it never uses it. It seems ie4 is always the default but neither
document.all nor window.event are used. Therefore I'm not sure why Mozilla does
not see the scrollable text in the page center.
(Assignee)

Comment 3

15 years ago
OK. Found it. The reason is http://www.arimr.gov.pl/js/dynlayer.js

This is an old version of DynAPI 
(formerly http://www.dansteinman.com/dynapi/, now
http://dynapi.sourceforge.net/dynapi/)
which does not support Mozilla (and therefore Netscape 6/7)
Depends on: 55458
(Assignee)

Comment 4

15 years ago
Mateusz Mazur <vincent@waw.pd.net> is cetainly the same Mateusz Mazur who used
<vincent@waw.pdi.net> address on Usenet groups until December 2001 then
<mefis@pit.gda.pl> until August 2002 and since September uses
<matmaz@niecierpiespamu.wp.pl>. The time seqence of this Google Groups serch
result is compelling. Of course, I know how to de-spamify the last address.
(Assignee)

Comment 5

15 years ago
Probably using the Gecko corrected version of the 1999 Dynapi library upgraded
by Bob Clary http://www.bclary.com/dynapi/ would work. It is hard to test it
remotely as the scripts depend on local directory names.
Depends on: 54458
No longer depends on: 55458
(Assignee)

Comment 6

15 years ago
Sent an evangelic letter with the dynapi advice to info, postmaster, webmaster 
@arimr.gov.pl with BCC: copies to vincent@waw.pdi.net and matmaz AT wp.pl 
Target Milestone: Oct → Dec
(Reporter)

Comment 7

15 years ago
 info@arimr.gov.pl has been contacted on Jun. 04, 2002 by one of our users.
Reply has been received on Jul. 29, 2002. It's content (in Polish) can be read
on MozillaPL.org Forum: http://mozillapl.org/forum/viewtopic.php?p=5587#5581
(Assignee)

Updated

15 years ago
Blocks: 54458
No longer depends on: 54458
(Assignee)

Updated

15 years ago
Alias: arimr.gov.pl
(Assignee)

Comment 8

15 years ago
Second evangelic letter sent.
Target Milestone: Dec → Feb
(Assignee)

Comment 9

15 years ago
I got a replay from Pazura.Rafal@arimr.gov.pl that the new standard comaptible
version is being prepared.
(Assignee)

Comment 10

15 years ago
No progress. Futuring the bug.
Target Milestone: Feb → Future
Summary: www.arimr.gov.pl - I do not like ARIMR web page [document.all, document.layers] → arimr.gov.pl - I do not like ARIMR web page [document.all, document.layers]

Comment 11

15 years ago
tech evang june 2003 reorg
Component: Europe: Central → Polish
Target Milestone: Future → ---
(Assignee)

Updated

15 years ago
Target Milestone: --- → Future
(Assignee)

Comment 12

14 years ago
It seems the site is fixed. Marking as such.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

14 years ago
Yup it really was :)
Marking Verified.
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.