Closed Bug 1759820 Opened 11 months ago Closed 10 months ago

Searched text highlight jumps around in pdf while zoomed in

Categories

(Core :: Graphics: WebRender, defect)

All
macOS
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox-esr91 --- unaffected
firefox98 --- unaffected
firefox99 --- unaffected
firefox100 --- verified

People

(Reporter: peter.magyari, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Steps to reproduce:

  1. Open Firefox.
  2. Navigate to https://unec.edu.az/application/uploads/2014/12/pdf-sample.pdf
  3. Open the find-in-text search bar (ctrl+f/ cmd+f).
  4. Select and copy the following text from inside the PDF:
    "Adobe® Portable Document Format (PDF) is a universal file format that preserves all
    of the fonts, formatting, colours and graphics of any source document, regardless of
    the application and platform used to create it."
  5. Paste it into the search bar.
  6. Start zooming in on the highlighted area. (350%+ )

Expected results:
The phrase is highlighted on the page correctly, regardless of how zoomed-in the page is.

Actual results:
The highlight starts jumping around on higher zoom percentages (see screenshot).

Notes
I've ran a mozregression and got the following pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f82c4fff86642fb89c830e03a5375aef17017272&tochange=7e01ab125e4caeeeb7bdb0a58471f502063b1e19

I suspect Bug 1758168 or Bug 1757876 might've introduced this issue.
Glenn, would you mind taking a look?

Flags: needinfo?(gwatson)

I wasn't able to reproduce this at all locally (running a build from m-c tip) - I'm testing on a Linux machine, though it seems unlikely to be something platform-specific given the possible regressing bugs. Is it still occurring for you? Could you paste the contents of your about:support? Is there anything else you can think of that might affect why I can't reproduce it locally, I'm guessing it occurs 100% of the time for you?

Flags: needinfo?(gwatson) → needinfo?(peter.magyari)

Glenn, this is only reproducible on Mac.

I tried this out on mac. I can't see the major artifact that is shown in the screenshot above, but I was seeing an artifact that I think is probably the same thing - the rounded corners on the last line of the highlighted text sometimes disappear at certain zoom levels.

I tried to mozregression, it pointed me to https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=3e93c8e836ff3fb0c0a953d6451adf188ada355f&tochange=bc83efda9211c1acde76885293fea37067b8b5cc

It's quite difficult to bisect since it seems like a different artifact on my machine (that may or may not be the same as this issue) and it's also difficult to conclusively say whether it's occurring or not since it's quite intermittent.

https://bugzilla.mozilla.org/show_bug.cgi?id=1377072 from my mozregressions sound sort-of related, but then unlikely to cause corner segments to be missing, that seems more like a WR issue.

When you reproduce it locally, is it always a major artifact like the screenshot or sometimes minor? Is it 100% reproducible? I also wonder if it might be fixed by https://bugzilla.mozilla.org/show_bug.cgi?id=1759647 which is currently on autoland and should end up in a nightly soon.

TYLin, I think my mozregression check was probably wrong - but does your patch in https://bugzilla.mozilla.org/show_bug.cgi?id=1377072 sound like it could possibly cause this issue?

Flags: needinfo?(aethanyc)

Hi Glenn,

The artifacting is not always the same, however, after a few zoom-in/zoom-outs I can reproduce it every time.
From my experience, it seems that most of the time it starts at 390% zoom level.
I'll attach one more example below.

Flags: needinfo?(peter.magyari)

Thanks Peter. The patch from https://bugzilla.mozilla.org/show_bug.cgi?id=1759647 should be in the next nightly - would you mind seeing if you can still reproduce then? It's possible, though unlikely, that this patch will fix this issue.

Flags: needinfo?(peter.magyari)

I've checked and the issue is still reproducible on Nightly 100.0a1 (20220320213921)

Flags: needinfo?(peter.magyari)
Flags: needinfo?(aethanyc)
Flags: needinfo?(aethanyc)

(In reply to Peter_M from comment #0)

Notes
I've ran a mozregression and got the following pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f82c4fff86642fb89c830e03a5375aef17017272&tochange=7e01ab125e4caeeeb7bdb0a58471f502063b1e19

I suspect Bug 1758168 or Bug 1757876 might've introduced this issue.
Glenn, would you mind taking a look?

Peter, since bug 1758168 was uplifted to 99 and bug 1757876 wasn't, could you try reproducing this on 99?
We can rule one of the bugs out this way.

Flags: needinfo?(peter.magyari)
Keywords: regression

Hi Marco,

I wasn't able to reproduce the issue on earlier Betas either (versions before the uplift)

Flags: needinfo?(peter.magyari)

(In reply to Peter_M from comment #10)

Hi Marco,

I wasn't able to reproduce the issue on earlier Betas either (versions before the uplift)

Are you able to reproduce it on the beta with the uplift?

Flags: needinfo?(peter.magyari)

(In reply to Marco Castelluccio [:marco] from comment #11)

(In reply to Peter_M from comment #10)

Hi Marco,

I wasn't able to reproduce the issue on earlier Betas either (versions before the uplift)

Are you able to reproduce it on the beta with the uplift?

No.

Flags: needinfo?(peter.magyari)
Component: PDF Viewer → Graphics: WebRender
Product: Firefox → Core
Has Regression Range: --- → yes

TYLin is in parental leave but that patch does seem quite unlikely to introduce something like this, the PDF viewer doesn't use position: sticky.

Flags: needinfo?(aethanyc)

Sounds like this is hopefully the same as https://bugzilla.mozilla.org/show_bug.cgi?id=1761299 (which I can repro and will investigate today).

I suspect this will be fixed by the patch in https://bugzilla.mozilla.org/show_bug.cgi?id=1761299. There is a pending try https://treeherder.mozilla.org/jobs?repo=try&revision=09d86463a695c6a09562fd22fc05d9cc620e9133 here if you would like to test, otherwise it should end up in nightly in the next day or so.

With https://bugzilla.mozilla.org/show_bug.cgi?id=1761299 in nightly, would you be able to check if this is resolved for you?

Flags: needinfo?(peter.magyari)

I can no longer reproduce it on the latest Nightly 100.0a1 (20220327213550)

Flags: needinfo?(peter.magyari)

Perfect, thanks!

Status: NEW → RESOLVED
Closed: 10 months ago
Depends on: 1761299
Resolution: --- → FIXED
Flags: qe-verify+

Reproducible on a 2022-03-16 Nightly 100.0a1 build(20220316214937) on macOS 11 using the steps from the Description. Verified as fixed on Firefox 100.0(20220425210429) and Nightly 101.0a1(20220425213655) on macOS 11, Ubuntu 20.04 and Win10 64-bits.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.