Quitting Mozilla when offline causes it to crash

VERIFIED DUPLICATE of bug 171782

Status

--
critical
VERIFIED DUPLICATE of bug 171782
16 years ago
14 years ago

People

(Reporter: khamilton, Assigned: asa)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2b) Gecko/20021016

On Mozilla 1.2b, Windows binary, I first noticed this at home on Windows 95,
after quitting my ISP, if I subsequently exit Mozilla, the system tells me
Mozilla has crashed.  It was easy enough to reproduce at work, on Windows NT
4.0, just "go offline" then attempt to exit Mozilla.  The talkback crash ID from
the Windows NT test is TB12919974G.

Reproducible: Always

Steps to Reproduce:
1. Push the button at the lower right, and "go offline".
2. Exit Mozilla.
3.

Actual Results:  
System warned that Mozilla had crashed.

Expected Results:  
Should have exited without incident.

Updated

16 years ago
Component: Browser-General → Build Config
Keywords: crash, stackwanted

Updated

16 years ago
Severity: normal → critical
nsDownloadManager::~nsDownloadManager 
[c:/builds/seamonkey/mozilla/xpfe/components/download-
manager/src/nsDownloadManager.cpp, line 99] 
nsDownloadManager::`scalar deleting destructor' 
nsDownloadManager::Release 
[c:/builds/seamonkey/mozilla/xpfe/components/download-
manager/src/nsDownloadManager.cpp, line 88] 
nsSupportsArray::Clear 
[c:/builds/seamonkey/mozilla/xpcom/ds/nsSupportsArray.cpp, line 560] 
nsSupportsArray::DeleteArray 
[c:/builds/seamonkey/mozilla/xpcom/ds/nsSupportsArray.cpp, line 304] 
nsSupportsArray::`vector deleting destructor' 
nsCOMPtr_base::~nsCOMPtr_base 
[c:/builds/seamonkey/mozilla/xpcom/glue/nsCOMPtr.cpp, line 65] 
ReleaseObserverList 
[c:/builds/seamonkey/mozilla/xpcom/ds/nsObserverService.cpp, line 110] 
_hashEnumerateRemove [c:/builds/seamonkey/mozilla/xpcom/ds/nsHashtable.cpp, 
line 381] 
PL_HashTableEnumerateEntries [plhash.c, line 430] 
nsHashtable::Reset [c:/builds/seamonkey/mozilla/xpcom/ds/nsHashtable.cpp, line 
398] 
0x007984f0 
nsSupportsHashtable::`vector deleting destructor' 
nsValueArray::Capacity 
[c:/builds/seamonkey/mozilla/xpcom/build/../ds\nsValueArray.h, line 75] 
nsIDKey::`vector deleting destructor' 
nsValueArray::Capacity 
[c:/builds/seamonkey/mozilla/xpcom/build/../ds\nsValueArray.h, line 75] 
nsFileSpecImpl::AddRef 
[c:/builds/seamonkey/mozilla/xpcom/io/nsFileSpecImpl.cpp, line 48] 
0xf98b5708 
Keywords: stackwanted

*** This bug has been marked as a duplicate of 171782 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
v.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.