Closed Bug 1760754 Opened 7 months ago Closed 4 months ago

Page content does not fully load on threenow.co.nz with ETP - Strict enabled

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

Firefox 100
Desktop
Windows 10
defect

Tracking

()

VERIFIED FIXED
103 Branch
Tracking Status
firefox100 --- wontfix
firefox103 --- fixed

People

(Reporter: oanaarbuzov, Assigned: twisniewski)

References

(Blocks 1 open bug, )

Details

Attachments

(2 files)

Attached image StandardVSStrict.png

Environment:
Browser / Version: Firefox Nightly 100.0a1 (2022-03-21)
Operating System: Windows 10 Pro
VPN active pointing to New Zealand

Steps to Reproduce:

  1. Navigate https://www.threenow.co.nz/
  2. Observe the page.

Expected Behavior:
The page content fully loads.

Actual Behavior:
Only the upper side of the site loads.

Note:

  1. With ETP - Standard.
  2. Screenshot attached.

It appears that the site expects the Nielsen tracker to load, and so because it's content-blocked in strict mode, the page breaks.

It looks as though we may be able to get away with a simple shim which just defines window.nol_t as a function returning undefined (upon network requests for https://secure-nz.imrworldwide.com/v60.js)

Severity: -- → S3

I've just confirmed that the shim proposed above will fix this site.

Blocks: 1773100
Assignee: nobody → twisniewski
Status: NEW → ASSIGNED
Pushed by twisniewski@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fea5e6f4b2e0
add a SmartBlock shim for the Nielsen tracker; r=ksenia,webcompat-reviewers
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 103 Branch

I can confirm this is fixed, the page content fully loads now.
https://prnt.sc/i1RSdjJanvx2

Tested with:
Browser / Version: Firefox Nightly 105.0a1 (2022-08-15)
Operating System: Windows 10 Pro

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.