Closed Bug 1760895 Opened 6 months ago Closed 6 months ago

[wpt-sync] Sync PR 33310 - Reland "Create property tree nodes for will-change only when relevant property has will-change."

Categories

(Core :: Web Painting, task, P4)

task

Tracking

()

RESOLVED FIXED
100 Branch
Tracking Status
firefox100 --- fixed

People

(Reporter: mozilla.org, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 33310 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/33310
Details from upstream follow.

L. David Baron <dbaron@chromium.org> wrote:

Reland "Create property tree nodes for will-change only when relevant property has will-change."

This is a reland of commit 5d3dd81ee4f41ffc7fd40fda745cb097cd50e9f5

Original change's description:

Create property tree nodes for will-change only when relevant property has will-change.

Prior to this change, will-change: transform, opacity, filter, or
backdrop-filter would cause the creation of property tree nodes (in both
the paint property tree and the cc property tree) for all of them
(though only a single effect property node for both opacity and
backdrop-filter).

With this change, will-change: transform only causes the creation of a
transform node (in the transform tree), will-change: filter only causes
the creation of a filter node (in the effect tree), and will-change:
opacity or backdrop-filter only causes the creation of an effect node
(in the effect tree). However, if the nodes are created by something
else, the presence of a different will-change still causes any node that
is created in the paint property tree to be composited (i.e., created in
the cc property tree).

This provides the basis on which we can separate the transform node into
multiple transform nodes, for efficient implementation and animation of
individual transform properties, without causing a performance
regression.

Earlier versions of this CL (prior to the change that kept nodes being
composited for an unrelated will-change) caused the test
external/wpt/css/filter-effects/effect-reference-feimage-002.html to
start failing (in the same way as -001 and -003) because the filter
effect is no longer composited. It creates a copy of the test as -004
with will-change: filter rather than will-change: transform that
continues to have a composited filter effect node and thus continues
passing even with that earlier change. This test still seems worth
adding despite no longer strictly being needed.

Bug: 900241
Change-Id: I18efc630668ea7eac2a8c0a0417b766762e71d9f
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3328730
Reviewed-by: Xianzhu Wang \<wangxianzhu@chromium.org>
Commit-Queue: David Baron \<dbaron@chromium.org>
Cr-Commit-Position: refs/heads/main@{#983821}

Bug: 900241
Change-Id: Ic760f2d303f56c1ab9c276a510b9eff82e53179b
Reviewed-on: https://chromium-review.googlesource.com/3543395
WPT-Export-Revision: 30f26888dc1fa839757e5802a51ca2b12c7c5073

Component: web-platform-tests → Web Painting
Product: Testing → Core

CI Results

Ran 0 Firefox configurations based on mozilla-central, and Firefox, Chrome, and Safari on GitHub CI

Total 1 tests

Status Summary

Firefox

PASS: 1

Chrome

PASS: 1

Safari

FAIL: 1

Links

GitHub PR Head
GitHub PR Base

Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6b4461f3dda7
[wpt PR 33310] - Reland "Create property tree nodes for will-change only when relevant property has will-change.", a=testonly
Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/87bad8070d68
[wpt PR 33310] - Reland "Create property tree nodes for will-change only when relevant property has will-change.", a=testonly
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 100 Branch
You need to log in before you can comment on or make changes to this bug.