cellspacing not viewable with different bgcolor

VERIFIED INVALID

Status

()

Core
Layout
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: Stefan Pietschmann, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
if a bgcolor is chosen for td or tr, that is different than the page background,
and a cellspacing > 0 is chosen, you cannot see the page background in the
spaces between the tables, but it's filled with the td bgcolor.

err.... just compare such a table in ie and phoenix and you know what i mean ;)
(Reporter)

Comment 1

16 years ago
Created attachment 103766 [details]
the table in IE
(Reporter)

Comment 2

16 years ago
Created attachment 103767 [details]
same table in phoenix - c the difference?

Comment 3

16 years ago
Stefan, have you tried if the problem also exists on Mozilla? Rendering issues
like this are almost always a Mozilla problem and not a Phoenix problem. Please
download a current mozilla nightly and change the product if the bug occurs also
in Mozilla.

Comment 4

16 years ago
Created attachment 103891 [details]
Testcase

WFM, both Mozilla and Phoenix, 20021023. 
I tried to create a table to reproduce the bug. I see no problems. 
Reporter, do you see the bug in this testcase? If not, can you upload a
testcase that exposes the bug?
(Reporter)

Comment 5

16 years ago
Created attachment 103899 [details]
as you wish - the testcase

you will see that the difference is that the colors are assigned via css, not
in the td or tr tags, so that must be the reason.

Comment 6

16 years ago
->browser
Assignee: blaker → other
Component: General → Layout
Product: Phoenix → Browser
QA Contact: asa → gerardok
Version: unspecified → other

Updated

16 years ago
QA Contact: gerardok → madhur

Comment 7

16 years ago
This bug is invalid.

look at source of testcase attachment 103899 [details] :-
-----------------------------------------------
<style type="text/css">
	body {background-color: #CCCCCC;}
	table.maintable { border-width: 0px;
			  width: 100%;
			  border-collapse: collapse;}
	.th { height: 2px;
		  background-color: #999999;
		  padding-left: 4px;
		  padding-right: 4px;
		  padding-top: 1px;
		  padding-bottom: 1px;
		  font-family: BodoniMutant;
		  color: black;
		  font-size: 15pt;}
	.cell { text-align: center;
		height: 18px;
		width: 14%;
		background-color: #f0f0f0;
		font-family: Verdana;
		font-size: 8.5pt; }
</style>
----------------------------------------------------------------

table has been given a style "border-collapse: collapse"
which is causing the the cellspacing to be ezqual to 0, hence the page
background color is not showing through.
if u remove the "border-collapse: collapse" from the style statement, u will see
cell spacing between the cells.

Also see http://www.w3.org/TR/REC-CSS2/tables.html#collapsing-borders for more
details.

closing the bug as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

16 years ago
why is that? look at the last testcase, then look at the image i made of the
table in ie. it's obviously a bug, isn't it?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 9

16 years ago
This is because IE does not support the the 'collpased border model' completely.

->invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 10

16 years ago
ok, I will have to accept that then, but I have to say that I think it sucks
that mozilla doesn't show it like IE does.

If i have tables with spaces in between them i should be able to see the
background colour in the spaces. It makes no sense that I can do it if I specify
the bgcolor in the td-tag, but it doesn't work if it's specified in CSS.

This is still a bug for me....I'll leave it as invalid though b/c I prolly have
nothing to say.

Comment 11

16 years ago
Stefan --
The reason Mozilla does not display the table in your testcase like IE is
because, Mozilla supports the 'Collapse border model' specified in the w3c
standards (http://www.w3.org/TR/REC-CSS2/tables.html#collapsing-borders),
whereas, IE does not. When u give "border-collapse: collapse" in the style for
the table, the HTML cellspacing is overwritten. That is why u do not see any
space between the cells, heance you can not see the body color in between.

If u really desire the background color to show through between the table 
cells, replace the "border-collapse:collapse" style by
"border-collapse:seperate". This should do the trick for you.

Status: RESOLVED → VERIFIED

Comment 12

16 years ago
.. or simply remove the line "border-collapse:collapse" from your css.
You need to log in before you can comment on or make changes to this bug.