A preference references Ctrl on Mac when it should be Command

RESOLVED FIXED

Status

SeaMonkey
Tabbed Browser
--
trivial
RESOLVED FIXED
15 years ago
9 years ago

People

(Reporter: Vincent Béron, Assigned: jag (Peter Annema))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.0.1) Gecko/20021021
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.0.1) Gecko/20021021

The "Middle-click or control-click of links in a Web page" preference should be
"... or command-click of ..." on Mac.
The string is in locale/communicator/pref/pref-tabs.dtd, middleClick.label.
The fix should make it the same way as the next one, urlbarWinUnix.label and
urlbarMac.label.

Reproducible: Always

Steps to Reproduce:
1. Open Edit -> Preferences.
2. Navigator -> Tabs

Actual Results:  
In the second group of checkboxes, the first one says "Ctrl" on Mac.


Expected Results:  
In the second group of checkboxes, the first one should be "Command" on Mac.
(Reporter)

Comment 1

15 years ago
Created attachment 103781 [details] [diff] [review]
Fix for branch mozilla-1_0

Proposed patch for the branch Mozilla-1_0
reporter: 
pöease send a MAIL to get reviews. YOu need ar= (ask on irc) and a sr=
(www.mozilla.org/hacking)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: patch, review
(Reporter)

Comment 3

15 years ago
Created attachment 103803 [details] [diff] [review]
Fix for branch trunk

Proposed patch for the trunk
(Assignee)

Comment 4

15 years ago
Comment on attachment 103803 [details] [diff] [review]
Fix for branch trunk

I would rather see this patch go in on both the trunk and the branch. sr=jag.
Attachment #103803 - Flags: superreview+
(Reporter)

Comment 5

15 years ago
Then I need to update the corresponding xul file as well, since for now it
doesn't search in the platform specific dtd in the branch 1-0. I'll attach a new
patch for branch 1-0 doing just that.
(Reporter)

Comment 6

15 years ago
Created attachment 103860 [details] [diff] [review]
Fix for branch mozilla-1_0 (modified files only)

This is the first part, which handles only modified files. It implements the
same thing as in the trunk. Another pacth is needed to create the proper files
fr this to work.
(Reporter)

Updated

15 years ago
Attachment #103781 - Attachment is obsolete: true
(Reporter)

Comment 7

15 years ago
Created attachment 103861 [details] [diff] [review]
Fix for branch mozilla-1_0 (new files only)

This patch creates (backports from the trunk, in fact) some files from the
en-US/mac directory. It must be used in conjonction with attachment #103860 [details] [diff] [review].
(Assignee)

Comment 8

15 years ago
Comment on attachment 103860 [details] [diff] [review]
Fix for branch mozilla-1_0 (modified files only)

sr=jag
Attachment #103860 - Flags: superreview+
(Assignee)

Comment 9

15 years ago
Comment on attachment 103861 [details] [diff] [review]
Fix for branch mozilla-1_0 (new files only)

sr=jag
Attachment #103861 - Flags: superreview+
(Assignee)

Comment 10

15 years ago
Comment on attachment 103781 [details] [diff] [review]
Fix for branch mozilla-1_0

I'd like to see the previous two patches get checked into the branch, but if it
can't be done because of l10n constraints or because drivers think it's too
risky, sr=jag on this patch, if you fix the nit pointed out below.

>Index: xpfe/components/prefwindow/resources/content/pref-tabs.xul

>+	string = document.getElementById("macMiddleClickPref");
>+	checkbox = document.getElementById("middleClick");
>+	checkbox.label = string.getAttribute("label");

Spaces, not tabs.
Attachment #103781 - Attachment is obsolete: false
Attachment #103781 - Flags: superreview+
Comment on attachment 103803 [details] [diff] [review]
Fix for branch trunk

a=dbaron for trunk checkin.  (Can all platforms potentially have a
middle-click?)
Attachment #103803 - Flags: approval+
Comment on attachment 103803 [details] [diff] [review]
Fix for branch trunk

This should be tested before it is checked in, though.
(Reporter)

Comment 13

15 years ago
Tested correctly with Mozilla 1.2b on Mac OS9.
I still don't see a checkin message.
(Reporter)

Comment 15

15 years ago
Who is entitled to check it in?
In other words: who should I bug?
This has approval.  If it doesn't get checked in by the early morning tree
closure on Nov 5, 2002 it's going to have to wait until after the branch is cut.
We're still waiting on this for the 1.2 branch.  It's going to miss the boat soon.

Comment 18

15 years ago
reporter: jag or I would check it in, but there are four attachments, and I
couldn't figure out which ones need to be committed to the branch. if you can
visit irc.mozilla.org #mozilla and contact jag or me (timeless) there, that'd be
great. if you miss us (unlikely), someone else on the channel would probably be
willing to commit it for you.

all i really need to know is which attachments to check in.
(Assignee)

Comment 19

15 years ago
None of the attachments seem to have r=, nor does this seem to have been landed
on the trunk yet.

timeless, could you r= and land this on the trunk? The same patch should (still)
pretty smoothly apply to the 1.2 branch.
(Assignee)

Comment 20

15 years ago
I think it's the second patch that would/should apply to the trunk.
(Reporter)

Comment 21

15 years ago
Yes, it's the second one. ID=103803.
(Reporter)

Comment 22

15 years ago
This bug has been fixed in CVS since November 2002. Should be marked Resolved/Fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.