Closed Bug 1761019 Opened 2 years ago Closed 2 years ago

Intermittent TV dom/webgpu/mochitest/test_buffer_mapping.html | Unhandled exception InvalidStateError: WebGPU is not enabled!

Categories

(Core :: Graphics: WebGPU, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1761014
Tracking Status
firefox-esr91 --- unaffected
firefox98 --- unaffected
firefox99 --- unaffected
firefox100 --- affected

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Filed by: ccozmuta [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=372060010&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/BD2ShubjTgOEdNbTgbFouw/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/BD2ShubjTgOEdNbTgbFouw/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


[task 2022-03-23T13:07:09.568Z] 13:07:09     INFO - TEST-START | dom/webgpu/mochitest/test_buffer_mapping.html
[task 2022-03-23T13:07:09.685Z] 13:07:09     INFO - GECKO(9040) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to C:\Users\task_164803838149565\AppData\Local\Temp\tmp73__ul96.mozrunner\runtests_leaks_tab_pid9172.log
[task 2022-03-23T13:07:09.685Z] 13:07:09     INFO - GECKO(9040) | [9172, Main Thread] WARNING: XPCOM_MEM_BLOAT_LOG is set, disabling native allocations.: file /builds/worker/checkouts/gecko/tools/profiler/core/platform.cpp:283
[task 2022-03-23T13:07:09.739Z] 13:07:09     INFO - GECKO(9040) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to C:\Users\task_164803838149565\AppData\Local\Temp\tmp73__ul96.mozrunner\runtests_leaks_tab_pid6876.log
[task 2022-03-23T13:07:09.750Z] 13:07:09     INFO - GECKO(9040) | [6876, Main Thread] WARNING: XPCOM_MEM_BLOAT_LOG is set, disabling native allocations.: file /builds/worker/checkouts/gecko/tools/profiler/core/platform.cpp:283
[task 2022-03-23T13:07:10.720Z] 13:07:10     INFO - TEST-INFO | started process screenshot
[task 2022-03-23T13:07:10.781Z] 13:07:10     INFO - TEST-INFO | screenshot: exit 0
[task 2022-03-23T13:07:10.792Z] 13:07:10     INFO - Buffered messages logged at 13:07:10
[task 2022-03-23T13:07:10.793Z] 13:07:10     INFO - TEST-PASS | dom/webgpu/mochitest/test_buffer_mapping.html | Pref should be enabled. 
[task 2022-03-23T13:07:10.793Z] 13:07:10     INFO - Buffered messages finished
[task 2022-03-23T13:07:10.794Z] 13:07:10     INFO - TEST-UNEXPECTED-FAIL | dom/webgpu/mochitest/test_buffer_mapping.html | Unhandled exception InvalidStateError: WebGPU is not enabled! 
[task 2022-03-23T13:07:10.794Z] 13:07:10     INFO -     SimpleTest.ok@SimpleTest/SimpleTest.js:417:16
[task 2022-03-23T13:07:10.794Z] 13:07:10     INFO -     @dom/webgpu/mochitest/test_buffer_mapping.html:36:19
[task 2022-03-23T13:07:10.795Z] 13:07:10     INFO - GECKO(9040) | MEMORY STAT | vsize 2103731MB | vsizeMaxContiguous 93145230MB | residentFast 67MB | heapAllocated 8MB
[task 2022-03-23T13:07:10.796Z] 13:07:10     INFO - TEST-OK | dom/webgpu/mochitest/test_buffer_mapping.html | took 1181ms
[task 2022-03-23T13:07:10.808Z] 13:07:10     INFO - TEST-START | Shutdown

:aosmond, since you are the author of the regressor, bug 1760810, could you take a look?
For more information, please visit auto_nag documentation.

Flags: needinfo?(aosmond)

Set release status flags based on info from the regressing bug 1760810

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(aosmond)
Resolution: --- → DUPLICATE
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.