Mailnews gave up on importing Outlook Express mail ["Unable to create the folder to import mail into"]

RESOLVED DUPLICATE of bug 142537

Status

MailNews Core
Import
--
major
RESOLVED DUPLICATE of bug 142537
16 years ago
10 years ago

People

(Reporter: Stefan Lasiewski, Assigned: Cavin Song)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826

I have a bunch of email stored in Outlook Express 5.0. I want to import this
email into Mozilla.

However, when I use the wizard, the wizard says it is "Unable to create the
folder to import mail into".

Reproducible: Always

Steps to Reproduce:
1. Start Mozilla
2. Go to Mail & Newsgroups via "Windows: Mail & Newsgroups" menu
3. Select "Tools: Import..." from the menu
4. Presented with the Import wizard. Under "Select the type of material to
import:", I have 3 choices: Address Books, Mail, Settings. 
5. Select "Mail" and hit Next
6. Presented with a list of "program from which you would like to import".
7. I select "Outlook Express" and hit Next
8. Get an error.



Actual Results:  
I immediately get an error. There is no perceivable disk access (e.g. Mozilla
has not performed an extensive search to find Outlook Express folders).

The error box says: "An error occured importing mail from Outlook Express.
Unable to create folder to import mail into".

Clicking the Back button does nothing. The only way out of this error box is to
hit "Finish".

Expected Results:  
Mozilla should have created a folder to store imported email, and then asked me
the next step in the import process.



At least one other person has seen this same problem. I found this on
groups.google.com:

http://groups.google.com/groups?q=%22Unable+to+create+folder+to+import+mail+into%22

Comment 1

16 years ago
confirming based on dupes: bug 79243, bug 120480, bug 101341
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Import mail into MozillaMail wizard is broken → Mailnews gave up import before even attempting Outlook Express mail import

Comment 2

16 years ago
FYI:  I see *exactly* the same behavior, but on a RedHat Linux 7.3 system,
attempting to import from Communicator 4.x.  I'm using Mozilla 1.2.1.

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 142537 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Summary: Mailnews gave up import before even attempting Outlook Express mail import → Mailnews gave up on importing Outlook Express mail ["Unable to create the folder to import mail into"]

Comment 4

15 years ago
I seem to have a solution(!), and suggest *reopening* this bug since it 
appears to be quite different from 142537: In this bug, there is NO 
conversion, and the error ("Unable to create the folder to import 
mail into") immediately happens, whereas in 142537, some progress 
happens, and then the error ("cannot create proxy object") occurs.

CAUSE OF PROBLEM:

The 'Local Directory' path of the mail can be changed by the user. It 
seems if it is changed from the default, the import will not work.
(not positive if the reporter of this bug had done this, but this
is how it happened for me.)

TEMPORARY WORK AROUND FOR USERS:

1. Close all Mozilla windows.

2. Move (or copy) your mail back to the default directory:
   -For example, my original default path was something like
   (yours will be different):
   C:\Documents and Settings\joe\Application
Data\Mozilla\Profiles\default\sbwvnghm.slt\Mail

3. Start Mozilla mail, and change the mail directory path back
   to default:
   -Edit -> Mail Account Settings -> Server Settings
         -> Local Directory

4. Import:
   -Tools -> Import -> Mail

5. Close all Mozilla windows

6. Move (or copy) the imported mail to the folder you want it
   to be in:
   -You will find the imported mail in the path from step 2.

7. Start Mozilla mail, and change the mail directory path
   to the one from step 6:
   -Follow step 3, but use path from step 6.

SUGGESTION TO DEVELOPERS FOR FIX:

I encountered this error with Win2K SP4, Mozilla ver. 1.5, attempting
to import both Outlook (XP) and Outlook Express (v 6.0) mail.

Seems that the import function is looking to the *default*
'Local Directory' path instead of the one set by the user...

THANKS FOR MAKING MOZILLA KICK!!
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.