Closed Bug 1761437 Opened 11 months ago Closed 11 months ago

Language switching and restart causes strange artifacts in tree views for English texts

Categories

(Core :: Graphics: Text, defect)

Desktop
Unspecified
defect

Tracking

()

VERIFIED FIXED
100 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox98 --- unaffected
firefox99 --- unaffected
firefox100 --- verified

People

(Reporter: aflorinescu, Assigned: lsalzman)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image mangled search engines
[Description:]

I've noticed this mostly in localizations that use special chars. Once it happens, I haven't figured a way to restore a readable search engine list - excluding another live language switching.

[Environment:]

100.0a1 (2022-03-24)

Windows 10 / Ubuntu 20
Mac 11 - not reproducible

[Preconditions:]
Configs:

intl.multilingual.downloadEnabled: true
intl.multilingual.enabled: true
intl.multilingual.liveReload: true
browser.search.log: true

Tools:

language packs
search-addon if needed, preferably in a separate FX for default engine checks

[Steps:]
  1. Install a firefox Firefox locale, en-us for example (autoset region not that relevant).
  2. Install zh-CN language pack from the preconditions.
  3. Open about:preferences / Language.
  4. Switch the language to zh-cn.
  5. Restart Firefox.
  6. Open about:preferences#search and check the search engines list.
[Actual Result:]

Engines names contain artefacts. (interemittent, depends on which language the switch change happens to)

[Expected Result:]

Engine names are readable at all times.

[Note:]

This issue might get fixed or altered when bug 1758730 lands.

It's really close to S3, but given that once it happens, the about:preferences#search engine list looks unusable, I'll set S2 for now pending further triage.

Severity: -- → S2

Does this reproduce without intl.multilingual.liveReload: true? It sounds like it could be an existing issue.

(In reply to Greg Tatum [:gregtatum] from comment #2)

Does this reproduce without intl.multilingual.liveReload: true? It sounds like it could be an existing issue.

Yes, profiles used for testing use the user.js config from preconditions.

Handing this to the search team for further triage, as it seems like an issue in the backend of the search engine store (rather than just the prefs use of that code), if this happens after a restart.

Component: Preferences → Search

I can reproduce this with or without live reload enabled. This only seems to affect Windows, though Linux may also be affected (see bug 1761888).

It also seems to affect tree views specifically.

STR:

  1. Have then en-US nightly installed/running.
  2. Set intl.multilingual.enabled to true
  3. Install the zh-CN language pack from https://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central-l10n/linux-x86_64/xpi/
  4. Open the bookmarks sidebar.
  5. Go to Settings -> General and find the language section.
  6. At the drop down, select the Chinese language, then click Apply & Restart

Results

English text in the bookmarks sidebar is displayed with strange artifacts.
Settings -> Search -> Search Shortcuts are also displayed with strange artiafacts.

An additional restart fixes them.

The search engine names in other places seem to be displayed correctly, so I don't think this is an issue with the search service. For example, the default engine drop-down on the same settings page and the tooltips on the one-off buttons on the address bar are both displayed correctly.

No longer blocks: 62174
Severity: S2 → --
Component: Search → Graphics: Text
Product: Firefox → Core
See Also: → 1761888
Summary: Restart causes about:preferences#search artefacts in engine # list → Language switching and restart causes strange artifacts in tree views for English texts
See Also: → 1759891
Flags: needinfo?(lsalzman)

I am unable to reproduce this on Linux following the STR. Can you try again on a more recent nightly?

Flags: needinfo?(lsalzman) → needinfo?(adrian.florinescu)

I can confirm this reproduces for me on Windows with today's Nightly (2022-03-29).

Regressed by: 1758555
No longer regressed by: 1759891

The shared font namespace was getting allocated by the RenderBackend, while
we otherwise allocated namespaces for documents on the client. We need to make
sure that if namespace allocation happens on the client, that it also happens
on the client fot the shared font namespace. This adds to RendererOptions to
make passing in a shared font namespace allocated by the client possible.

Assignee: nobody → lsalzman
Status: NEW → ASSIGNED
Flags: needinfo?(adrian.florinescu)
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/806e9fc2d511
Ensure the shared font namespace is allocated by the client. r=gw
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 100 Branch
Has Regression Range: --- → yes
Flags: qe-verify+

Verified as fixed using Firefox 100.0b4 and Nightly 101.0a1 (2022-04-12) on Ubuntu 22.04, Mac 11 and Windows 10.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.