Closed Bug 1761476 Opened 11 months ago Closed 10 months ago

break point

Categories

(DevTools :: Debugger, defect, P3)

Firefox 99
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1658546

People

(Reporter: rwalterdiego, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:99.0) Gecko/20100101 Firefox/99.0

Steps to reproduce:

It happens sometimes when I'm developing using the debugger and I get an error in my code. The debugger shows me an exception error. So I go to my code and make some changes to fix the problem. Then I go to Firefox Developer and refresh the page and sometimes the debugger keeps stopping at the same place where the error was. But now there is no error to show. It's like there is a breakpoint left but it doesn't show it, so there is no way to remove the breakpoint because I didn't set a breakpoint and the debugger doesn't show it but it still stops there even when I refresh the page again with F5 or Shift+F5.

Actual results:

do not stop where there is no longer an error

Expected results:

continue with page load

The Bugbug bot thinks this bug should belong to the 'DevTools::Debugger' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Debugger
Product: Firefox → DevTools
Severity: -- → S3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3

I believe this is dup of Bug 1658546

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.