bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Browser crashes on startup after sidebar minimised



Core Graveyard
Profile: Migration
19 years ago
2 years ago


(Reporter: ssym, Assigned: selmer (gone))


Windows 95

Firefox Tracking Flags

(Not tracked)



(2 attachments)



19 years ago

My preferences have been migrated to Mozilla 5.0, and I prefer to have both mail
and browser start up after I launch the program.  This and the sidebar seem to
be causing a crash.


1.  Set up a profile in Navigator 4.x (I use 4.7).  Make sure that the profile
causes both mail and browser to be launched at startup.
2.  Migrate your preferences to 5.0.
3.  Start up Mozilla, minimize the side-bar in the browser.
4.  Close Mozilla.
5.  Start it up again.


The mail section seems to load fine, with everything displaying perfectly and
(if you're quick with the mouse!) you can even click on a button before it
crashes.  So mail seems to work nicely ... then when it apparently tries to get
to the browser, it crashes.  See the ADDITIONAL INFORMATION below for the output
from the "Details..." button after the crash.


Perhaps ths browser should start up?  And even not crash? =)


Build 1999102908, using Windows 95 ver 4.00.1111


Here's the stuff from the "Details..." button after the crash:

MOZILLA caused an invalid page fault in
module GKHTML.DLL at 0137:601f302b.
EAX=00000000 CS=0137 EIP=601f302b EFLGS=00010206
EBX=00dc4180 SS=013f ESP=0063f008 EBP=0063f0a4
ECX=00dc4180 DS=013f ESI=00dc26b0 FS=144f
EDX=00dc4180 ES=013f EDI=00dc0c0c GS=0000
Bytes at CS:EIP:
ff 10 8b 45 10 8d 55 f8 52 68 50 e6 26 60 8b 08
Stack dump:
00dc0c0c 00dc4188 00dc26e8 00000000 00000000 00000000 00000000 60b33a28 00000010
00000040 00000001 00000000 00000000 000000aa 00000000 00000000

Note that this error does NOT occur if mail AND browser are not set to show up
at startup!

Comment 1

19 years ago
Created attachment 2505 [details]
FAULTLOG file from the crash

Comment 2

19 years ago
Just submitted a FAULTLOG file, it comes from the crash I just mentioned...

As a side note, to fix this, it is not enough to erase mozregistry.dat fron
\windows.  You also need to deltree the contents of your Users50
directory...then you're back to square one, typing "mozilla -installer" and
setting up the whole thing again!


19 years ago
Component: Sidebar → Profile Migration

Comment 3

19 years ago
After furthur testing (with Build 1999103008) it seems that Mozilla crashes with
the same error EVEN IF you don't touch the sidebar, and even if you only have
one thing (browser) starting up.  Since this ONLY happens to me (so far!) with
migrated profiles, I'm changing the component to "Profile Migration" ... sorry
for any inconvenience in the mean time...


19 years ago
Assignee: slamm → selmer
QA Contact: paulmac → gbush

Comment 4

19 years ago
changing QA contact and assignee due to new component


19 years ago
QA Contact: gbush → paulmac

Comment 5

19 years ago
ssym, I need your help to try to narrow down what the problem is. It seems like
something in your 4.x profile that migrates is causing the crash. You can
confirm this by creating a new profile using the command apprunner.exe
-installer    If you don't have problems with this 'clean' profile, then we know
the problem is with your 4.x profile.

So then there are a few possibilities. My first guess is the home page. Have you
tried different home pages? You can try creating a new, simple profile in 4.7
then migrating it over. This *should* work, it's part of our daily smoketests.

Let us know if you come up with something.

Comment 6

19 years ago
Sorry, paulmac, your hypothesis seems to have failed....  Here is what I did:

I created a new, clean profile using 4.7.  Then, without erasing mozregistry or
the current migrated profiles (should I have done that?) I migrated the new
profile (called "test") to Mozilla (mozilla.exe -installer).  The homepage of
the new profile was the default one, I didn't make any changes, just created a
default and migrated.

When I simply ran the browser, nothing special happened, everything worked fine
... I exited and came back with no problem at all.  Then I started
experimenting, and clicked on (in this order):

1. the Mailbox icon, and put the information it requested in.  Closed Mailbox.
2. the Editor icon, and clicked briefly on the two buttons ("Browser" and
"Normal") at the bottom of that window.  Closed Editor.
3. the Addressbook icon, and closed it as soon as it loaded.
4. the Browser icon, until two windows were open and maximised.  I then pressed
Ctrl-N to get a new window up, and maximised it.

Closed everything down, when I tried to start "test" up again, it crashed with
the same error.  Now the only prefs I added in were the ones Mailbox
requested... make of this what you will, should I attach the "test" prefs.js
file anyway?

Using the same build as before, i.e. 1999103008, same platform, Win95.

Comment 7

19 years ago
ssym, please create a profile WITHOUT using 4.7 (or any other 4.x version.)  Run
mozilla with the -ProfileManager option and then use it to create a new 5.0
profile.  Then, try your tests again.

Thanks,  Steve


19 years ago
Target Milestone: M20

Comment 8

19 years ago
Setting TFV to M20 to get this off the radar until we know who should own this.

Comment 9

19 years ago
New profile (MozProfileX) created with mozilla.exe -ProfileManager, and I put it
through the exact same tests, closed it, started it again, and no problem
occurred.  Did this a few more times, trying out permutations of original tests
(loading stuff in editor, clicking on links, getting mail) and still no problem
starting up.

As I said previously, it is only my migrated profiles that have this trouble,
Mozilla-created ones are fine.

BTW, I am now using Build 1999110108

Comment 10

19 years ago
Yes, please attach your prefs file. That may or may not be the problem, but I
couldn't recreate your crash following all of those steps, starting with a new
4.7 profile, migrating it over, etc.

You might try deleting some other things in your Users50 directory and see if
that has any effect. Even deleting your prefs.js file (but not the whole
directory). Thanks, we'll figure this out eventually.

Comment 11

19 years ago
Created attachment 2569 [details]
This (migrated) prefs.js crashes consistently on startup.

Comment 12

19 years ago
Thanks for the info, I will look into this.

Comment 13

19 years ago
ssym, I still couldn't reproduce. Here's what I did:

1. Create a new profile and launch.
2. Shutdown
3. Add the contents of your prefs.js to the new profile's empty prefs.js
4. Launch

Results: Slashdot.org came up as the home page. Messenger came up also. However,
no crash occurred. I was able to shutdown and restart again.

Am I missing something? I tried this using a nov.5 build.

Comment 14

19 years ago

keep that Nov 5 build handy.  I'll conduct a few tests using the Nov 5 build,
after completely erasing all traces of other builds on my system.  Then I'll
experiment and tell you what I come up with so that you can duplicate.  I'll get
back to you within the week, probably within the next 2-3 days in fact.

Comment 15

19 years ago
I cannot seem to get properly reproducible results.  It seems to crash after
extended browsing; after such browsing it will not start up again without the
error.  But I've found after following the instructions below, and then starting
it up and surfing around a bit more, I generally manage to reprodce.  Not the
best procedure, but I cannot seem to find a common link, so here goes:

Start with a new Mozilla...delete old profiles, old program files, old
mozregistry, everything.
run mozilla -installer
Mozilla starts, maximise window, wait to /. to load, quit it.
Start up mozilla again.
The way my profile is set up, Mail & News loads in foreground, maximise it.
Click on the '+' next to news.ru.ac.za to open it.
Click on netscape.public.mozilla.ui.
Wait for it to load up, click on the panel to thread messages.
Close Mail.
The only Mozilla window now open is the browser, maximise window and type in the
location box the address: audiograbber.n3.net
Wait for it to load, click on "FULL version of Audiograbber 1.60" link at top of
You'll get a popup window for babylon-x, wait for it to load, close it.
Wait about 5 - 10 seconds, close ALL open Mozilla windows.

Now surf around for about 1/2 an hour, afterwards it should not start up

Obviously, use the prefs.js file that is an attachment ....

IMHO, would it be better to change the resolution to WORKSFORME or REMIND/LATER
until this is clearer?


19 years ago
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 16

19 years ago
Yes, I can't reproduce, probably part of it has to do with the fact I don't have
the rest of your profile that also gets migrated over. Let's sit on this for
awhile and see if it still happens in a month or so.

Marking worksforme.

Thanks for taking all the time to investigate this, sorry I couldn't duplicate
your results.

Comment 17

18 years ago
Sorry for the spam, changing QA contact.
QA Contact: paulmac → gbush

Comment 18

18 years ago

I am verifying as WORKSFORME with latest builds- 2000-04-28-09, if you are still 
experiencing problem, please reopen and update
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.