Closed Bug 1761576 Opened 9 months ago Closed 6 months ago

Intermittent browser/components/sessionstore/test/browser_upgrade_backup.js | upgrade backup should be set - "" == "20220325194501" - JS frame :: chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_upgrade_backup.js :: test

Categories

(Firefox :: Session Restore, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1435394
Tracking Status
firefox-esr91 --- unaffected
firefox98 --- unaffected
firefox99 --- unaffected
firefox100 --- wontfix

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 obsolete file)

Filed by: mlaza [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=372382859&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/HaBmd2-SQFKH2KrCBQZ9Hw/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/HaBmd2-SQFKH2KrCBQZ9Hw/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


[task 2022-03-25T20:06:25.756Z] 20:06:25     INFO - TEST-START | browser/components/sessionstore/test/browser_upgrade_backup.js
[task 2022-03-25T20:06:26.295Z] 20:06:26     INFO - TEST-INFO | started process screencapture
[task 2022-03-25T20:06:26.416Z] 20:06:26     INFO - TEST-INFO | screencapture: exit 0
[task 2022-03-25T20:06:26.416Z] 20:06:26     INFO - Buffered messages logged at 20:06:25
[task 2022-03-25T20:06:26.416Z] 20:06:26     INFO - Entering test bound init
[task 2022-03-25T20:06:26.417Z] 20:06:26     INFO - Leaving test bound init
[task 2022-03-25T20:06:26.417Z] 20:06:26     INFO - Entering test bound test_upgrade_backup
[task 2022-03-25T20:06:26.417Z] 20:06:26     INFO - Let's check if we create an upgrade backup
[task 2022-03-25T20:06:26.418Z] 20:06:26     INFO - Buffered messages logged at 20:06:26
[task 2022-03-25T20:06:26.418Z] 20:06:26     INFO - Call `SessionFile.read()` to set state to 'clean'
[task 2022-03-25T20:06:26.418Z] 20:06:26     INFO - Buffered messages finished
[task 2022-03-25T20:06:26.419Z] 20:06:26     INFO - TEST-UNEXPECTED-FAIL | browser/components/sessionstore/test/browser_upgrade_backup.js | upgrade backup should be set - "" == "20220325194501" - JS frame :: chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_upgrade_backup.js :: test_upgrade_backup :: line 55
[task 2022-03-25T20:06:26.419Z] 20:06:26     INFO - Stack trace:
[task 2022-03-25T20:06:26.419Z] 20:06:26     INFO - chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_upgrade_backup.js:test_upgrade_backup:55
[task 2022-03-25T20:06:26.420Z] 20:06:26     INFO - Not taking screenshot here: see the one that was previously logged
[task 2022-03-25T20:06:26.420Z] 20:06:26     INFO - TEST-UNEXPECTED-FAIL | browser/components/sessionstore/test/browser_upgrade_backup.js | Uncaught exception in test - OperationError: Could not parse path (): NS_ERROR_FILE_UNRECOGNIZED_PATH
[task 2022-03-25T20:06:26.421Z] 20:06:26     INFO - Stack trace:
[task 2022-03-25T20:06:26.421Z] 20:06:26     INFO - test_upgrade_backup@chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_upgrade_backup.js:62:19
[task 2022-03-25T20:06:26.421Z] 20:06:26     INFO - Leaving test bound test_upgrade_backup
[task 2022-03-25T20:06:26.422Z] 20:06:26     INFO - Entering test bound test_upgrade_backup_removal
[task 2022-03-25T20:06:26.422Z] 20:06:26     INFO - Let's see if we remove backups if there are too many
[task 2022-03-25T20:06:26.422Z] 20:06:26     INFO - Call `SessionFile.read()` to set state to 'clean'
[task 2022-03-25T20:06:26.423Z] 20:06:26     INFO - Write the session to disk and perform a backup
[task 2022-03-25T20:06:26.520Z] 20:06:26     INFO - TEST-PASS | browser/components/sessionstore/test/browser_upgrade_backup.js | upgrade backup should be set - 
Summary: Intermittent TV browser/components/sessionstore/test/browser_upgrade_backup.js | upgrade backup should be set - "" == "20220325194501" - JS frame :: chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_upgrade_backup.js :: test → Intermittent browser/components/sessionstore/test/browser_upgrade_backup.js | upgrade backup should be set - "" == "20220325194501" - JS frame :: chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_upgrade_backup.js :: test
Regressed by: 1752853

Set release status flags based on info from the regressing bug 1752853

:mathew.hodson, since you are the author of the regressor, bug 1752853, could you take a look?
For more information, please visit auto_nag documentation.

Flags: needinfo?(mathew.hodson)
Has Regression Range: --- → yes

I guess it's some kind of race, but I don't get it. Could the test harness allow test_upgrade_backup() to run before init() is finished?

Flags: needinfo?(mathew.hodson)

We need to wait until initialization is complete before starting
any tests.

Assignee: nobody → mathew.hodson
Status: NEW → ASSIGNED

Comment on attachment 9281548 [details]
WIP: Bug 1761576 - Replace init tasks with add_setup in tests. r?Gijs

Revision D149486 was moved to bug 1776578. Setting attachment 9281548 [details] to obsolete.

Attachment #9281548 - Attachment is obsolete: true
Assignee: mathew.hodson → nobody
Status: ASSIGNED → NEW

This seems like it's a duplicate of much older bug 1435394. The message just changed since the tests were updated in bug 1752853.

Assignee: nobody → mathew.hodson
Attachment #9281548 - Attachment description: Bug 1761576 - Use `add_setup` in browser_upgrade_backup.js test. r?Gijs → WIP: Bug 1761576 - Replace init tasks with add_setup in tests. r?Gijs
Attachment #9281548 - Attachment is obsolete: false
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
No longer regressed by: 1752853
Resolution: --- → DUPLICATE
See Also: → 1752853

Comment on attachment 9281548 [details]
WIP: Bug 1761576 - Replace init tasks with add_setup in tests. r?Gijs

Revision D149486 was moved to bug 1776578. Setting attachment 9281548 [details] to obsolete.

Attachment #9281548 - Attachment is obsolete: true
Assignee: mathew.hodson → nobody
You need to log in before you can comment on or make changes to this bug.