Multiple monitors: Display Find window near active browser

RESOLVED INVALID

Status

--
enhancement
RESOLVED INVALID
16 years ago
11 years ago

People

(Reporter: mu, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
Future
PowerPC
Mac OS X

Details

(Reporter)

Description

16 years ago
Selecting "Find in Page" currently results in the "Find" window showing up in
the place where the user has put it the last time. While this is perfect for
1-monitor setups, it doesn't work well for setups with multiple monitors.

Here, a user might be working with 3 browser windows on three monitors. When he
is looking into the leftmost monitor and presses Cmd-F, the Find window might
appear in the rightmost monitor, going unnoticed by the user since the
appearance occured out of his field of vision and didn't catch his eyes. The
user would be confused quite a bit as a result. Furthermore, he would need to
constantly move the "Find" window manually towards any browser window he wants
to work with in order to see a page and the find controls at the same time.

I suggest that for multiple monitors setups, the "Find in page" window be
displayed on the monitor containing the active browser.

Comment 1

16 years ago
Reporter, what build ID are you reporting this bug against?
(Reporter)

Comment 2

16 years ago
Build ID 2002.10.20.04

Comment 3

16 years ago
Confirm. Should note this in bug 160771.
Assignee: saari → pinkerton
Status: UNCONFIRMED → NEW
Ever confirmed: true
makes sense
Status: NEW → ASSIGNED
Target Milestone: --- → Chimera1.1

Comment 5

16 years ago
is bug 205945 a dupe?

Comment 6

16 years ago
*** Bug 205945 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Blocks: 236647
QA Contact: winnie → general
Target Milestone: Camino1.1 → Future

Comment 7

13 years ago
Should we WONTFIX this in favour of the Fx-like Find Toolbar (bug 258211), which would be anchored in the (active) window and therefore remove the need for this bug?

cl
I don't think we've come to an agreement on eliminating the Find panel, since it's standard Cocoa UI.  Until such point, if ever, that the Find panel is eliminated, this bug should remain open.

Comment 9

12 years ago
I think instead of remembering Find window position, we should center it on the active window. Presumably, the active window doesn't move around much, so that approach would result in approximately the same overall behaviour we have now, without the "Where'd my Find window run off to?" reaction.
Assignee: mikepinkerton → nobody
Status: ASSIGNED → NEW
Find panel is no more.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.