Closed Bug 1761886 Opened 6 months ago Closed 2 months ago

The homepage for Basic authentication or Digest authentication remains loading at startup and is not displayed.

Categories

(Toolkit :: Password Manager, defect, P3)

Firefox 100
defect

Tracking

()

VERIFIED FIXED
105 Branch
Tracking Status
firefox105 --- verified

People

(Reporter: sin, Assigned: dimi)

References

Details

Attachments

(10 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:100.0) Gecko/20100101 Firefox/100.0

Steps to reproduce:

If all of the following conditions, the homepage for Basic or Digest authentication remains loading at startup and is not displayed.

-Set a Web page URL for Basic authentication or Digest authentication in "Homepage and new windows"
-You have enabled uBlock Origin in extensions
-You have already logged in to your Firefox account.
-You set master password.
-You set to delete the cache with "Clear history when Nightly closes"

Actual results:

The homepage remains loading at startup and is never displayed.

Expected results:

The homepage is displayed.

The Bugbug bot thinks this bug should belong to the 'Toolkit::Password Manager' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Password Manager
Product: Firefox → Toolkit

:sin, can you provide a link to the example web page with Basic or Digest Authentication?

Is it necessary to have uBlock Origin to be active? Is it blocking selected web pages?

Example access authentication web pages are

Basic auth page: https://hccbe.com/test/basic-auth/
Username:user, Password:password

Digest auth page: https://hccbe.com/test/digest-auth/
Username:user, Password:password

You need to save these login information(username and password) in the browser.

uBlock Origin extension need to be enabled. But, you can disable it for this site.

Flags: needinfo?(sgalich)

I can not reproduce the issue on Firefox Nightly 101. I'm getting Primary Password prompts, basic/digest auth prompts, page loads with some "success" message on it.

:sin, can you try similar steps with Chrome/Edge browsers. Or attach some screenshots (perhaps I misunderstand expected outcome).

Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Flags: needinfo?(sgalich) → needinfo?(sin)
Resolution: --- → WORKSFORME
Flags: needinfo?(sin)

I uploaded some image files.
Microsoft Edge does not have this issue.

Thank you :sin, these screenshots and log helps a lot!

Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---

The severity field is not set for this bug.
:sgalich, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(sgalich)
Assignee: nobody → dlee
Severity: -- → S3
Flags: needinfo?(sgalich)
Priority: -- → P3
Pushed by dlee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7b06f88af5c5
Use js promise correctly in LoginManagerAuthPrompter.jsm r=sgalich
Status: REOPENED → RESOLVED
Closed: 6 months ago2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 105 Branch
Duplicate of this bug: 1779790
Duplicate of this bug: 1769400

This problem no longer occurs on Nightly 105.0a1 (2022-08-02).
Thank you.

QA Whiteboard: [qa-105b-p2]

I managed to reproduce this issue on a 2022-07-30 Nightly build on Ubuntu 22.04 using the STR in the Description and comments. Verified as fixed on Firefox 105.0b8(build ID: 20220906185728) and Nightly 106.0a1(build ID: 20220906092849) on Ubuntu 22.04, macOS 12, Windows 10.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-105b-p2]
You need to log in before you can comment on or make changes to this bug.