compose window doesn't accept keystrokes after keyboard navigating to it until mouse click in message body

VERIFIED DUPLICATE of bug 173818

Status

VERIFIED DUPLICATE of bug 173818
16 years ago
10 years ago

People

(Reporter: pje, Assigned: bugzilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016

When opening a new message and using TAB to navigate down to the message body,
keystrokes go nowhere although the cursor blinks and sits there.  It requires a
mouse click in the message window to get keystrokes to register, after which all
is well.  This bug was not around until 1.2 beta on my Linux box.

Reproducible: Always

Steps to Reproduce:
1. Open new message (CTRL-M or from menu)
2. Fill in To: email (or leave it blank)
3. TAB to Subject:
4. Fill in subject (or leave it blank)
5. TAB to message body window
6. Type some characters

Actual Results:  
No characters appear in message window until you click there with the mouse,
after which everything is peachy.

Expected Results:  
Keyboard should have let me begin to type the message.

Comment 1

16 years ago
Reporter, I tried your scenario with a 10-17 build on my linux system in both
Plain text compose and HTML compose windows and did not see this problem.  This
appears to be a dup of 173818 which was fixed on 10-17, I will mark this a dup
of that bug, but please take a current build to see the fix.

*** This bug has been marked as a duplicate of 173818 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
More info on this bug, reporter this bug states this happens with a New Msg
window, however with the 10-16 build on linux I can only see this problem with a
Reply Window when my default compose window is set to plain text compose for the
account I'm using.  The dup bug is for a Reply window too.  I tested this again
with the 10-17 build which had the fix and what I saw with the reply window is
fixed.  If your scenario does not include a reply window, and you still see this
with a current build please reopen this and give more details like the type of
compose window (plain text or HTML), the theme you are using, does this happen
in a 2nd compose window if you close the first one without clicking in the body
of the message.  Keeping this as dup for now.

Comment 3

16 years ago
OK, another dup bug 175665 mentions New Msg window with a plain text signature
has the problem.  This was the missing criteria to see the problem in a New Msg
window, I did see this and it is fixed too. 
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.