Closed Bug 1762429 Opened 10 months ago Closed 7 months ago

[Wayland] Copy'n'paste from Firefox to other applications in Wayland stops working after some time

Categories

(Core :: Widget: Gtk, defect, P3)

Firefox 98
x86_64
Linux
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mozilla-06, Unassigned)

References

(Blocks 2 open bugs)

Details

After some time, copy'n'pasting text (be it from the URL bar or from some website content) from Firefox to some other application stops working on my Wayland session.

Steps to reproduce:

  1. log in to a Wayland session with KDE Plasma
  2. start Firefox
  3. test that you can copy'n'paste text from the Firefox URL bar and from websites to other applications (e.g., Kate as a text editor)
  4. work for a few hours
  5. test again that you can copy'n'paste text from the Firefox URL bar and from websites to other applications (e.g., Kate as a text editor)

Expected result:
The copied text from the URL bar and the websites can be pasted to Kate.

Actual result:
Nothing is pasted to Kate (not even the text that was in the clipboard before).

Additional information:
I have no idea what exact time needs to pass before this problem occurs, or whether some specific action triggers this problem. I first though that hibernation/standby triggers this, but it doesn't.
Copy'n'pasting within Firefox and from Kate to Firefox keeps working.
After restarting Firefox, copy'n'pasting will work again for some time.
I have not tested whether this problem occurs with an X11 session as well.

This is with Firefox 98.0.2 from Kubuntu 21.10 in the DEB version (not the Snap version).on KDE Plasma 5.24.4 with KDE frameworks 5.92.0 and Qt 5.15.2.

Potentially related: bug 1752505

The Bugbug bot thinks this bug should belong to the 'Core::Widget: Gtk' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: General → Widget: Gtk
Product: Firefox → Core
Summary: Copy'n'paste from Firefox to other applications in Wayland stops working after some time → [Wayland] Copy'n'paste from Firefox to other applications in Wayland stops working after some time
Priority: -- → P3

On Arch Linux running Wayland session of Plasma 5.24.4 and Firefox 99, copying from URL bar or via "Copy link" option from context menu never works when Firefox runs natively on Wayland. The same problem occurs on neon unstable distro running Firefox 99 and git version of KDE Plasma.

According to https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1913775, this might be a bug in GTK+.

… and this bug might or might not be a duplicate of bug 1722369.

Does this still happen for you on (and have you upgraded to Kubuntu 22.04)?

Flags: needinfo?(mozilla-06)

I have updated to 22.04 in the meantime, and I haven't had this problem anymore in the last few weeks. So AFAIC, we can close this bug as fixed.

Flags: needinfo?(mozilla-06)

Great, thanks!

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.