Closed Bug 1762747 Opened 2 years ago Closed 2 years ago

Perma [Tier 2] /scroll-to-text-fragment/find-range-from-text-directive.html | Suffix need not be start bounded. - assert_equals: Expected to scroll expected true but got false

Categories

(Testing :: web-platform-tests, defect, P5)

defect

Tracking

(firefox-esr91 unaffected, firefox98 unaffected, firefox99 unaffected, firefox100 fixed)

RESOLVED FIXED
100 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox98 --- unaffected
firefox99 --- unaffected
firefox100 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: CosminS)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(2 files)

Filed by: ccozmuta [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=373203185&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/X8dLAxDYR4yxF1vTEYe0yQ/runs/0/artifacts/public/logs/live_backing.log


[task 2022-04-02T23:42:10.723Z] 23:42:10     INFO - TEST-START | /scroll-to-text-fragment/find-range-from-text-directive.html
[task 2022-04-02T23:42:24.376Z] 23:42:24     INFO - .........................
[task 2022-04-02T23:42:24.376Z] 23:42:24     INFO - TEST-FAIL | /scroll-to-text-fragment/find-range-from-text-directive.html | overlapping one letter exact matches with suffix. - assert_equals: Expected to scroll expected true but got false
[task 2022-04-02T23:42:24.376Z] 23:42:24     INFO - @http://web-platform.test:8000/scroll-to-text-fragment/find-range-from-text-directive.html:301:18
[task 2022-04-02T23:42:24.376Z] 23:42:24     INFO - TEST-FAIL | /scroll-to-text-fragment/find-range-from-text-directive.html | matching range search. - assert_equals: Expected to scroll expected true but got false
[task 2022-04-02T23:42:24.376Z] 23:42:24     INFO - @http://web-platform.test:8000/scroll-to-text-fragment/find-range-from-text-directive.html:301:18
[task 2022-04-02T23:42:24.376Z] 23:42:24     INFO - TEST-PASS | /scroll-to-text-fragment/find-range-from-text-directive.html | inverted range search. 
[task 2022-04-02T23:42:24.376Z] 23:42:24     INFO - TEST-PASS | /scroll-to-text-fragment/find-range-from-text-directive.html | no suffix forces |end| to be end bounded. 
[task 2022-04-02T23:42:24.377Z] 23:42:24     INFO - TEST-FAIL | /scroll-to-text-fragment/find-range-from-text-directive.html | suffix means |end| need not be end bounded. - assert_equals: Expected to scroll expected true but got false
[task 2022-04-02T23:42:24.377Z] 23:42:24     INFO - @http://web-platform.test:8000/scroll-to-text-fragment/find-range-from-text-directive.html:301:18
[task 2022-04-02T23:42:24.377Z] 23:42:24     INFO - TEST-PASS | /scroll-to-text-fragment/find-range-from-text-directive.html | |end| must be start bounded. 
[task 2022-04-02T23:42:24.377Z] 23:42:24     INFO - TEST-PASS | /scroll-to-text-fragment/find-range-from-text-directive.html | |end| must be start bounded even if full range is word bounded. 
[task 2022-04-02T23:42:24.377Z] 23:42:24     INFO - TEST-PASS | /scroll-to-text-fragment/find-range-from-text-directive.html | non-existent |end|. 
[task 2022-04-02T23:42:24.377Z] 23:42:24     INFO - TEST-PASS | /scroll-to-text-fragment/find-range-from-text-directive.html | Range with preceeding suffix. 
[task 2022-04-02T23:42:24.377Z] 23:42:24     INFO - TEST-FAIL | /scroll-to-text-fragment/find-range-from-text-directive.html | Match with no suffix. - assert_equals: Expected to scroll expected true but got false
[task 2022-04-02T23:42:24.377Z] 23:42:24     INFO - @http://web-platform.test:8000/scroll-to-text-fragment/find-range-from-text-directive.html:301:18
[task 2022-04-02T23:42:24.377Z] 23:42:24     INFO - TEST-KNOWN-INTERMITTENT-PASS | /scroll-to-text-fragment/find-range-from-text-directive.html | Suffix comes before |end|. 
[task 2022-04-02T23:42:24.378Z] 23:42:24     INFO - 
[task 2022-04-02T23:42:24.378Z] 23:42:24     INFO - TEST-KNOWN-INTERMITTENT-FAIL | /scroll-to-text-fragment/find-range-from-text-directive.html | Search invisible content between |end| and suffix. - assert_equals: Expected to scroll expected true but got false
[task 2022-04-02T23:42:24.378Z] 23:42:24     INFO - @http://web-platform.test:8000/scroll-to-text-fragment/find-range-from-text-directive.html:301:18
[task 2022-04-02T23:42:24.380Z] 23:42:24     INFO - 
[task 2022-04-02T23:42:24.380Z] 23:42:24     INFO - TEST-PASS | /scroll-to-text-fragment/find-range-from-text-directive.html | Suffix must be end bounded. 
[task 2022-04-02T23:42:24.380Z] 23:42:24     INFO - TEST-UNEXPECTED-FAIL | /scroll-to-text-fragment/find-range-from-text-directive.html | Suffix need not be start bounded. - assert_equals: Expected to scroll expected true but got false
[task 2022-04-02T23:42:24.380Z] 23:42:24     INFO - @http://web-platform.test:8000/scroll-to-text-fragment/find-range-from-text-directive.html:301:18
[task 2022-04-02T23:42:24.380Z] 23:42:24     INFO - TEST-INFO | expected NOTRUN
[task 2022-04-02T23:42:24.380Z] 23:42:24     INFO - 
[task 2022-04-02T23:42:24.381Z] 23:42:24     INFO - TEST-KNOWN-INTERMITTENT-PASS | /scroll-to-text-fragment/find-range-from-text-directive.html | Non-existent suffix. 
[task 2022-04-02T23:42:24.381Z] 23:42:24     INFO - 
[task 2022-04-02T23:42:24.381Z] 23:42:24     INFO - TEST-KNOWN-INTERMITTENT-PASS | /scroll-to-text-fragment/find-range-from-text-directive.html | Content appears between match and suffix. 
[task 2022-04-02T23:42:24.382Z] 23:42:24     INFO - 
[task 2022-04-02T23:42:24.382Z] 23:42:24     INFO - TEST-UNEXPECTED-FAIL | /scroll-to-text-fragment/find-range-from-text-directive.html | Non-matching suffix in first potential match. - assert_equals: Expected to scroll expected true but got false
[task 2022-04-02T23:42:24.382Z] 23:42:24     INFO - @http://web-platform.test:8000/scroll-to-text-fragment/find-range-from-text-directive.html:301:18
[task 2022-04-02T23:42:24.382Z] 23:42:24     INFO - TEST-INFO | expected NOTRUN
[task 2022-04-02T23:42:24.383Z] 23:42:24     INFO - 
[task 2022-04-02T23:42:24.383Z] 23:42:24     INFO - TEST-UNEXPECTED-FAIL | /scroll-to-text-fragment/find-range-from-text-directive.html | Non-matching suffix search continues to prefix match. - assert_equals: Expected to scroll expected true but got false
[task 2022-04-02T23:42:24.383Z] 23:42:24     INFO - @http://web-platform.test:8000/scroll-to-text-fragment/find-range-from-text-directive.html:301:18
[task 2022-04-02T23:42:24.383Z] 23:42:24     INFO - TEST-INFO | expected NOTRUN
[task 2022-04-02T23:42:24.384Z] 23:42:24     INFO - 
[task 2022-04-02T23:42:24.384Z] 23:42:24     INFO - TEST-UNEXPECTED-FAIL | /scroll-to-text-fragment/find-range-from-text-directive.html | Range end matches correct suffix. - assert_equals: Expected to scroll expected true but got false
[task 2022-04-02T23:42:24.384Z] 23:42:24     INFO - @http://web-platform.test:8000/scroll-to-text-fragment/find-range-from-text-directive.html:301:18
[task 2022-04-02T23:42:24.384Z] 23:42:24     INFO - TEST-INFO | expected NOTRUN
[task 2022-04-02T23:42:24.385Z] 23:42:24     INFO - TEST-UNEXPECTED-OK | /scroll-to-text-fragment/find-range-from-text-directive.html | expected TIMEOUT
[task 2022-04-02T23:42:24.385Z] 23:42:24     INFO - TEST-INFO expected TIMEOUT | took 13642ms
[task 2022-04-02T23:42:24.387Z] 23:42:24     INFO - PID 2873 | 1648942944366	Marionette	INFO	Stopped listening on port 53572
[task 2022-04-02T23:42:24.723Z] 23:42:24     INFO - PID 2873 | ###!!! [Parent][PImageBridgeParent] Error: RunMessage(msgname=PImageBridge::Msg_WillClose) Channel closing: too late to send/recv, messages will be lost
[task 2022-04-02T23:42:24.859Z] 23:42:24     INFO - Browser exited with return code 0
[task 2022-04-02T23:42:24.862Z] 23:42:24     INFO - Closing logging queue
[task 2022-04-02T23:42:24.862Z] 23:42:24     INFO - queue closed
[task 2022-04-02T23:42:24.910Z] 23:42:24     INFO - Application command: /opt/worker/tasks/task_164894196881601/build/application/Firefox Nightly.app/Contents/MacOS/firefox --marionette about:blank -foreground -profile /var/folders/0y/lyz4b4sx50dg5sbmmsj0tn3r000014/T/tmp4t4faie0
[task 2022-04-02T23:42:24.920Z] 23:42:24     INFO - PID 2889 | 1648942930517	Marionette	INFO	Marionette enabled
[task 2022-04-02T23:42:24.921Z] 23:42:24     INFO - PID 2889 | console.warn: SearchSettings: "get: No settings file exists, new profile?" (new NotFoundError("Could not open the file at /var/folders/0y/lyz4b4sx50dg5sbmmsj0tn3r000014/T/tmp1o2qr5lm/search.json.mozlz4", (void 0)))
[task 2022-04-02T23:42:24.921Z] 23:42:24     INFO - PID 2889 | 1648942932318	Marionette	INFO	Listening on port 53671
[task 2022-04-02T23:42:24.921Z] 23:42:24     INFO - Starting runner
[task 2022-04-02T23:42:25.246Z] 23:42:25     INFO - PID 2889 | 2022-04-02 23:42:25.244 firefox[2889:75097] Persistent UI failed to open file file:///Users/cltbld/Library/Saved%20Application%20State/org.mozilla.nightly.savedState/window_1.data: No such file or directory (2)
[task 2022-04-02T23:42:25.486Z] 23:42:25     INFO - TEST-START | /scroll-to-text-fragment/force-load-at-top.html
Flags: needinfo?(james)
Regressions: 1762362
Assignee: nobody → csabou
Status: NEW → ASSIGNED

This is failing only on osx wpt backlog jobs. These backlog jobs run only on central. On "regular" wpt jobs looks like the tests are skipped, see https://treeherder.mozilla.org/logviewer?job_id=373203024&repo=mozilla-central&lineNumber=1291.

Regressed by: 1762362
No longer regressions: 1762362

Set release status flags based on info from the regressing bug 1762362

Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/a59398b52c9a
Update expectations for scroll-to-text-fragment tests on mac. r=aryx
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 100 Branch
Has Regression Range: --- → yes
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/bc04b987d35c
set scroll-to-text-fragment/force-load-at-top.html as always passing on macOS. DONTBUILD
Flags: needinfo?(james)
You need to log in before you can comment on or make changes to this bug.