Form data should not be restored from shist on forced-reload

RESOLVED WORKSFORME

Status

()

Core
Document Navigation
P2
major
RESOLVED WORKSFORME
16 years ago
7 years ago

People

(Reporter: brendan, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I see this all the time in bugzilla: comment in a bug, maybe add some cc:
entries, submit, click on the bug link to get the new version, repeat.  Then use
Go to back up N shist items to the original bug, see that it's out of date, hit
shift-reload, see the new comments, etc. -- but also (to my longstanding dismay)
see the comment and cc: changes restored from session history, wrongly/redundantly.

/be
(Reporter)

Comment 1

16 years ago
jkeiser, can you take this one?  Might be an easy 1.2final fix.

/be
Assignee: radha → jkeiser
Keywords: mozilla1.2
If it's happening on shift-reload that's bad.... (for normal reload it should be
happening, but not for shift-reload)
Severity: normal → major

Updated

16 years ago
Blocks: 179330

Comment 3

16 years ago
I cannot reproduce this (and could not before, either).  Is it still happening
for you?

Comment 4

16 years ago
-> triage bin.  I can't work on this until I can reproduce.
Assignee: jkeiser → radha
Priority: -- → P2
Target Milestone: --- → Future

Comment 5

15 years ago
Is or is not different from bug 46845?
This is supposedly different (in that it happens with shift-reload).  Brendan,
can you still reproduce this?
(Reporter)

Comment 7

15 years ago
Haven't seen this lately.  Anyone else?

/be
Worksforme, unless someone can produce a counterexample.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.