1.2 Beta on Mac Gives Blank display when closing non-active tab

RESOLVED DUPLICATE of bug 173703

Status

RESOLVED DUPLICATE of bug 173703
16 years ago
10 years ago

People

(Reporter: fillup, Assigned: jag-mozilla)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

221.87 KB, application/pdf
Details
39.06 KB, application/pdf
Details
(Reporter)

Description

16 years ago
Here's the process:

Open a page.  Right-click a link and open the link in new tab.  La la la, browse
along, open as many tabs as you like.  Right-click a tab for a page that you're
not viewing currently (non-active tab).  Click "Close tab".  Note that you just
get the wacky Aqua-background display (white/off-white lined window) with a
single "aqua bar" at the top.  See screenshot.

Nothin you do to this window will get you back to a usable state.  You have to
use a different window.  You've lost all your tabs.

Mozilla 1.2 Beta Mac OS X.  Happened on three different machines.  Doesn't
ALWAYS happen -- don't have time to test the conditions right now.  I know it
never happens if you have "load tabs in background" turned on and you never
switch away from your initial tab.  You have to switch around a bit, then close
a tab that you're not viewing.  Do this enough, and it'll happen....or I am 100%
insane.

See the screenshots (before and after).
(Reporter)

Comment 1

16 years ago
Created attachment 103892 [details]
Before

before the closing
(Reporter)

Comment 2

16 years ago
Created attachment 103893 [details]
after

After the closing

Comment 3

16 years ago
I'm able to reproduce this 100% on 2002102208, Mac OS X 10.1.5, by doing:
- open a new window with a page with several links (at least three)
- open three links from this page in new tabs (this is with "Load links in the
background" enabled) so you now have four tabs
- select the third tab
- Ctrl-click the second tab and select "Close Tab"; you should be looking at
what is now the second tab, but will see the content of the third tab
- Ctrl-click what is now the third tab, and close it; you should now see the
striped background

At this point, it can be recovered by going back to the first tab, then to the
second.  If, however, you close the confused tab, the window becomes difficult
to use.
(Assignee)

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 173703 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.